Tree-like hierachical browsing history view

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
16 years ago
a year ago

People

(Reporter: netdragon, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
This is broken off from bug 21521 because that bug was not only in the wrong 
component for history, but there is only supposed to be one-topic per bug. If 
this weren't done, it would have very little chance of getting fixed. 
Basically, this bug is about the following:

1)  Go to www.mozilla.org
2)  Click on "Mozilla organization" link
3)  Click on "Developer Docs" link
4)  Click on "NSPR"
5)  Click back two times
6)  Click on "Developer Docs" link
7)  Click in "Introductory Material" link
8)  Click on mozilla.org banner on top of page
9)  Type http://www.mozilla.org/
10) Click on Testing
11) Click on link to Bugzilla

A tree-like history to sort the navigation of sites.

|
+ mozilla.org
| |
| + mozilla.org
|   |
|   + Mozilla Documentation
|   | |
|   | + Mozilla Doc - Core Architecture: NSPR
|   |
|   + Mozilla Documentation
|   |
|   + Mozilla Doc - Introductory Material
|       |
|       + mozilla.org
|
+ www.mozilla.org
| |
| + Mozilla QA Home Page
|   |
|   + mozilla.org Bugzilla

The main issue is how deep do we let the tree nest and when do we start a new 
secondary node to the tree?

Comment 1

16 years ago
What about this alternate proposal in Bug 187187.

It seems simpler and basically does what you're after (maintains the forward
history instead of erasing it when you navigate from a page in your 'back history').

Comment 2

15 years ago
Note that NCSA Mosaic 3.0 had a similar feature.  Any single browsing session's
tree could be saved to and loaded from disk, but was lost between sessions if
not saved.  http://browsers.evolt.org/?mosiac-ncsa/

Comment 3

15 years ago
*** Bug 225268 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
*** Bug 199677 has been marked as a duplicate of this bug. ***
*** Bug 272717 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Assignee: firefox → nobody
QA Contact: claudius → core.history.global

Comment 6

13 years ago
The Firefox history sidebar is now recording mozilla.com and www.mozilla.com as separate entities; but both are listed under 'mozilla.com'.

Comment 7

12 years ago
https://addons.mozilla.org/firefox/1756/ - Referrer History. Works fine in Firefox 2.0.0.1. :)

Combine that with Firefox Showcase and Firefox 3 may be just as nifty as this Mosaic derivative from 1995(!): http://www.w3.org/Conferences/WWW4/Papers2/270/

Camino has a patch: bug 177959.

Firefox 3 bug 364426 got my hopes up but it's the usual group by domain tree.

Updated

2 years ago
Component: History: Global → Places
Product: Core → Toolkit
I don-t think this is a path we'll take, bookmarks hierarchy works, but for history it'd work to have a better search and filtering functionality.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.