Closed Bug 1874277 Opened 3 months ago Closed 3 months ago

Switching to Search Bar with TAB does not select the previous search term

Categories

(Firefox :: Search, defect, P2)

Firefox 123
defect

Tracking

()

VERIFIED FIXED
124 Branch
Accessibility Severity s3
Tracking Status
firefox-esr115 --- unaffected
firefox121 --- unaffected
firefox122 --- unaffected
firefox123 --- verified
firefox124 --- verified

People

(Reporter: flo, Assigned: ayeddi)

References

(Regression)

Details

(Keywords: access, regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:123.0) Gecko/20100101 Firefox/123.0

Steps to reproduce:

I still use the separate Search Bar. My usual workflow to search for something is Command+t TAB TermImLookingFor ENTER
This change in behavior first occured in nightly on 2024-01-02, it still works as expected in 2024-01-01. I can reproduce this on Windows and MacOS. Entering the Search Bar with Command+k still selects the search term as expected

Actual results:

Now in case there is a previous term in the Search Bar I'm searching for FirstSearchTermSecondSearchTerm, because FirstSearchTerm is not selected and doesn't get replaced with SecondSearchTerm, instead it's appended.

Expected results:

FirstSearchTerm schould be selected and replaced as soon as you start entering SecondSearchTerm

Hello, thank you for the bug report!
Managed to reproduce this issue on Nightly 123.0a1 on the following:

  • Windows 10;
  • macOS 12;
  • Ubuntu 22;

mozregression points to:

Setting the Component to ‘Search’. Please change if there’s a better fit, thank you.

Status: UNCONFIRMED → NEW
Component: Untriaged → Search
Ever confirmed: true
Keywords: regression
Regressed by: 1871596

Set release status flags based on info from the regressing bug 1871596

:ayeddi, since you are the author of the regressor, bug 1871596, could you take a look? Also, could you set the severity field?

For more information, please visit BugBot documentation.

Flags: needinfo?(ayeddi)
Duplicate of this bug: 1874764

Thank you for reporting the issue, :flo!

I'm investigating it, I think this may be caused by the custom keyboard navigation handling which is also affecting the bug 1871980 patch too (the same unit tests should be failing because of this bug, but apparently they are not - we'd need to include this in the test coverage too).

I'm assigning the bug to myself but will keep the NI for now. And will get back with updates or if the fix may be more complex, I'd probably work on reverting the regressing change until it's handled properly.

Assignee: nobody → ayeddi
Accessibility Severity: --- → s4
Keywords: access
See Also: → 1871980

Hi Anna,

We'd prefer not shipping a known regression that'd break users who operate on this workflow especially with muscle memory.

Do you plan on fixing the bug before the regression affects release users or are you thinking of reverting the regressing change?

Is the accessibility severity S4 too optimistic? We would rate this as an S3 due to the fact that a work around exists though for a vision impaired user it might be more of a severe bug.

(In reply to James Teow [:jteow] from comment #5)

Hi Anna,

We'd prefer not shipping a known regression that'd break users who operate on this workflow especially with muscle memory.

Do you plan on fixing the bug before the regression affects release users or are you thinking of reverting the regressing change?

Is the accessibility severity S4 too optimistic? We would rate this as an S3 due to the fact that a work around exists though for a vision impaired user it might be more of a severe bug.

Thank you for following up, I totally agree that we do not need to ship it, so I'll gather more info on the possible fix through tomorrow and, if it's not trivial, I'll have a revert patch ready on Jan 24 and will continue investigation. Keeping NI

Accessibility Severity: s4 → s3
Flags: needinfo?(ayeddi)
Depends on: 1875654

Patch D199309 is resolving the issue but I'll add a unit test under this bug atop of that patch to ensure the coverage too

Ensuring the test coverage is provided to avoid reappearance of the issue when re-focusing the Search bar with keyboard would not auto select the value of the input.

The bug is being resolved by bug 1875654.

Depends on D199309

Set release status flags based on info from the regressing bug 1871596

Pushed by ayeddi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/87af26a45872
Adding mochitest to ensure the search bar input field value is autoselected when it is focused. r=Standard8

Looks like this one might be in the pipe to completion. Anna, could you apply a Severity to this for posterity?

Flags: needinfo?(ayeddi)

(In reply to Bob Hood [:bhood] from comment #11)

Looks like this one might be in the pipe to completion. Anna, could you apply a Severity to this for posterity?

Sure thing - added.

Severity: -- → S3
Flags: needinfo?(ayeddi)
Priority: -- → P2
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 124 Branch

The patch landed in nightly and beta is affected.
:ayeddi, is this bug important enough to require an uplift?

  • If yes, please nominate the patch for beta approval.
  • If no, please set status-firefox123 to wontfix.

For more information, please visit BugBot documentation.

Flags: needinfo?(ayeddi)

Comment on attachment 9375919 [details]
Bug 1874277 - Adding mochitest to ensure the search bar input field value is autoselected when it is focused. r=Standard8!

Beta/Release Uplift Approval Request

  • User impact if declined: While this specific patch does not change the users behavior, the issue reported was resolved by the bug 1875654 was a blocker for keyboard users of Search Bar. Without the patch the resolved behavior won't have proper unit tests.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce: n/a
  • List of other uplifts needed: Bug 1875654
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The patch introduces a very limited change to the code base which is a unit test to confirm the issue has been and will stay resolved
  • String changes made/needed:
  • Is Android affected?: Yes
Flags: needinfo?(ayeddi)
Attachment #9375919 - Flags: approval-mozilla-beta?

Comment on attachment 9375919 [details]
Bug 1874277 - Adding mochitest to ensure the search bar input field value is autoselected when it is focused. r=Standard8!

Approved for 123 beta 3, thanks.

Attachment #9375919 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified as fixed on Firefox Nightly 124.0a1 and Firefox 123.0b3(treeherder build) on Windows 10, macOS 12, Ubuntu 22.

Status: RESOLVED → VERIFIED
Duplicate of this bug: 1877024
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: