All users were logged out of Bugzilla on October 13th, 2018

[FIX]link included in div-tag has active areas outside link

RESOLVED FIXED in mozilla1.3beta

Status

()

P1
normal
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: gwen, Assigned: bzbarsky)

Tracking

Trunk
mozilla1.3beta
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

div align=center tag includes an image which is a link. The area next to the
image is active, the image itself is active, too. Crosshair-Cursor is displayed
correctly outside proper active area but not inside.

Looks fine in IE and Opera, but not in Mozilla and Phoenix

(Please excuse my bad English...)

Reproducible: Always

Steps to Reproduce:
1. Open Phoenix or Mozilla (Windows or FreeBSD)
2. Open http://oui-ja.de/entry.php?id=00706
3. Move cursor over image and next to image

Actual Results:  
Active area where no active-link-area is supposed to be.

Expected Results:  
Show only an active area above the image

Comment 1

16 years ago
*** Bug 187429 has been marked as a duplicate of this bug. ***

Comment 2

16 years ago
You have submitted a Phoenix-specific bug, but you are mentioning in the bug
report that you have tested it in Mozilla with the same results (and thus it's
NOT a Phoenix-specific bug!).
Component: General → Layout
Product: Phoenix → Browser
Version: unspecified → Trunk
reassign
Assignee: blaker → other
QA Contact: asa → ian

Comment 4

16 years ago
Created attachment 110518 [details]
Testcase for bug #187428

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212 Used for this
test
(Assignee)

Comment 5

16 years ago
The cursor issue is caused by the following CSS in Mozilla's UA stylesheet:

*|*:-moz-any-link img, img[usemap], object[usemap] {
  border: 2px solid;
  cursor: pointer;
}

This sets the cursor to "pointer" on any image inside a link....  This could be 
rewritten as:

*|*:-moz-any-link img, img[usemap], object[usemap] {
  border: 2px solid;
}

img[usemap], object[usemap] {
  cursor: pointer;
}

Since we already set "cursor" on *|*:-moz-any-link in ua.css and that should 
inherit down to any images inside the link...

Of course given that rule all the rest of our behavior is correct; the only 
question is whether the rule should stay as-is.

As for the active region issue, the image is set to be a block and the entire 
block box (with width equal to the <body>) is thus inside the <a>.... and 
should all be active.
OS: Windows XP → All
(Reporter)

Updated

16 years ago
Summary: link included div-tag has active areas outside link → link included in div-tag has active areas outside link
The splitting in comment 5 makes sense to me.
(Assignee)

Comment 7

16 years ago
taking
Assignee: other → bzbarsky
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1
Target Milestone: --- → mozilla1.3beta
(Assignee)

Updated

16 years ago
Attachment #110678 - Flags: superreview?(dbaron)
Attachment #110678 - Flags: review?(dbaron)
(Assignee)

Updated

16 years ago
Summary: link included in div-tag has active areas outside link → [FIX]link included in div-tag has active areas outside link
Comment on attachment 110678 [details] [diff] [review]
patch

r+sr=dbaron if you move 'cursor: pointer' into the rule below rather than
creating a new rule
(Assignee)

Comment 10

16 years ago
Good catch... checked in with just the move to the existing rule.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Assignee)

Updated

16 years ago
Attachment #110678 - Flags: superreview?(dbaron)
Attachment #110678 - Flags: review?(dbaron)
You need to log in before you can comment on or make changes to this bug.