using a custom location for POP mail data (local directory) prevents viewing of incoming messages

VERIFIED DUPLICATE of bug 84952

Status

VERIFIED DUPLICATE of bug 84952
16 years ago
14 years ago

People

(Reporter: coder_1024, Assigned: racham)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

I specified a custom location for the data for a POP mail account
(account->server settings->local directory).  This was a local directory on my
machine.  I then checked my Email.  The new messages downloaded and I could see
the headers in the top pane.  When I clicked on the messages, however, nothing
showed up in the lower preview pane.  I then tried opening the messages and the
message window was empty. 

I then deleted the account and re-created it, this time leaving the default
"local directory" value.  This time it worked and I was able to view the messages.

Note that I reported a related bug (187382), where news accounts do not allow
you to provide a custom newsrc file location.

I think in general there are some problems with specification and use of storage
directories for both mail and news.


Reproducible: Always

Steps to Reproduce:
1. create a new mail POP account
2. specify a custom data location (account->server settings->local directory)
3. check Email

Actual Results:  
incoming messages showed up, but it was not possible to view the message contents

Expected Results:  
displayed the message

Perhaps the code which reads the message data (preview pane and message window)
just assumes the default location as opposed to using the user specified
location.  It then doesn't display it because the message doesn't exist at the
default location.

Comment 1

16 years ago
I'm adding some steps to clarify the behavior I see.
1) create new pop account
2) specify custom location
3) check email - behavior is as reporter described.
4) close & restart Mozilla
5) check email

After steps 4 & 5, worksforme.  Reporter, does this match the behavior on your
system?  Is so, please update Summary field.
(Reporter)

Comment 2

16 years ago
sort of...  I created a POP account, changed the folder location and then
checked Email.  I was unable to view the downloaded messages.  I then quit and
restarted.  I was still unable to view the messages.  I received a new message
and was unable to view it.
---
I then deleted the account, and created a new one with the same settings.  This
time, I quit and restarted BEFORE checking mail.  Once starting up again,
everything worked.
(Reporter)

Comment 3

16 years ago
so, not only do you have to quit and restart once you've changed the folder
location, its important that you DO NOT check for messages before restarting or
things appear to get hosed up.

Comment 4

16 years ago
I'm pretty sure this is a dup of bug 84952.  I'll add some comments there.

*** This bug has been marked as a duplicate of 84952 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.