Hotmail rtf/html editing and viewing not supported

VERIFIED DUPLICATE of bug 179314

Status

()

Core
Layout: Form Controls
VERIFIED DUPLICATE of bug 179314
15 years ago
15 years ago

People

(Reporter: Helge Stenström, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020611
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020611

Hotmail (www.hotmail.com) has the ability to write messages with color and
different fonts and font sizes. In what looks like an ordinary html FORM, the
writer can choose colors etc. Problably based on javascript? There is a setting
(Tools) where you can choose between plain text and rich text.
In Mozilla, the rich text editing mode cannot be turned on. There is no such choice.
In Mozilla, when looking at a saved message that was edited with rich text using
MSIE, html code appears in the form where there normally would only be text.

Reproducible: Always

Steps to Reproduce:
1. Get a hotmail account
2. Write a message using MSIE and rich text. Save it to a folder.
3. Go to the hotmail account using Mozilla. Look at the saved message. You see
html code.
4. Write a new message. Try to set the editing mode to rich text. There is no
such choice.
Actual Results:  
3. html code appears with the actual text, in the message editing window of hotmail.
4. The tools setting (a selector input close to the editing area) has only one
choice, which is not rich text)

Expected Results:  
3. The message should appear with font colors and sizes as it was originally
written and saved in MSIE.
4. There should be a choice for rich text in the selector input.

Sorry for my non-ideal terminology. I use Swedish hotmail and do not know html
very well. By selector input, I mean the kind of input where you can choose
between several items in a list. There is a little triangle to the right of the
input. An example is the Reproducibility input of the bugzilla page were I enter
this text (Every time, Some times but not always, ...)

The term "rich text" might be something else in engish language Hotmail.

I'm not sure if the component "Layout: Form controls" is the right one.

Comment 1

15 years ago
see bug 97284 for progress on implementing this feature in Mozilla and 
http://xopus.org/

*** This bug has been marked as a duplicate of 179314 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.