Closed Bug 18745 Opened 22 years ago Closed 22 years ago

Double-clicking widgets in the pref dialog freezes browser

Categories

(SeaMonkey :: Preferences, defect, P3)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: cvogler, Assigned: matt)

Details

Overview description: In the Linux/GTK+ build, double-clicking any widget in the
preferences dialog causes the browser to freeze.

Steps to reproduce:
1. Start up mozilla.
2. Open Edit/Preferences
3. Double-click on "Navigator" checkbox

Actual results: No events and redraws are handled anymore. The browser must be
killed by hitting CTRL-C in the shell window.

Expected results: Should behave like a single click on the checkbox

Build date and Platform: 11/12/1999, build 08 on Linux.

I don't know whether this happens on other platform and other widget toolkits.
May test with a Qt build if I find time.
Assignee: shuang → matt
The bug report used the old build. Looks like it is already fixed but I am not
sure since I don't run Linux build. reassing it to matt or anyone from QA for
help.
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED
Yep, this has been fixed for some time.
Status: RESOLVED → VERIFIED
Using the 1999121508 build under Linux, I don't see a crash. Marking verified.
Bulk move of all Pref UI component bugs to new Preferences component.  Pref UI 
component will be deleted.
Component: Pref UI → Preferences
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.