Clicking scrollbar in 2nd list scrolls elements of dropdown list.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: vocatan, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

When multiple listboxes are on the screen, a scrollbar mousedrag on a
multi-select list gets sent to a DROPDOWN listbox instead.

Very small html snippet to reproduce at URL supplied above.


Reproducible: Always

Steps to Reproduce:
1. Click on the 'dropdown' button to show the list of entries, 
2. click on the SCROLL bar of the 2nd list, and move the mouse around. 


Actual Results:  
The selected element from list1 will change!


Expected Results:  
The first dropdown listbox should NOT have scrolled, the 2nd list should have
scrolled.


Source code to demonstrate:

<form name=listbug>
List1:<select name=list1> <option>foo1 <option>foo2 <option>foo3 <option>foo4
<option>foo5 </select>
List2:<select name=list2 multiple size=3> <option>foo1 <option>foo2 <option>foo3
<option>foo4 <option>foo5 </select>
</form>
Does the dropdown close when you click on the scrollbar?

Comment 2

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212
I see it too.

To answer your question Boris No.
Ah, I see that. Looks like we don't take the popup down till the mouseup; we
should be taking it down onmousedown... Since the popup has mouse grab, things
break.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

15 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040817
Windows XP SP2

I suggest that this bug should be closed.

Comment 5

15 years ago
this wasn't a problem in 1.3.  marking WFM
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.