Print preview sometimes inserts bogus page breaks

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
17 years ago
11 years ago

People

(Reporter: nparks, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

17 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.3a) Gecko/20030102 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.3a) Gecko/20030102 Phoenix/0.5

I have encountered this bug with several nightlies.  The first time I was using
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.3a) Gecko/20021119 Phoenix/0.4

Go to the following page:

http://www.wrhs.org/media/starwars.htm

From the File menu, select Print Preview. Select either "shrink to fit" or 100
percent.

Where did that crazy page break come from?

Now select 90 percent, and the whole web page will fit nicely on 2 printed pages.


Reproducible: Always

Steps to Reproduce:

Comment 1

17 years ago
->print preview
Assignee: blaker → rods
Component: General → Print Preview
Product: Phoenix → Browser
QA Contact: asa → sujay
Version: unspecified → Trunk

Comment 2

16 years ago
I was able to duplicate this bug as described under Win98/Build 2003070308
(except I had to scale down to 80% instead of 90% to get it to fit on two
pages).  This page print-previews fine in IE6/NC4.8.

The crux of the matter seems to be:

<td valign="top" width="60" height="688">

near the bottom of the page, if the 'height="688"' is removed, then print
preview looks fine (i.e. it fits on two pages with the default "Shrink to Fit"
selected and no page break).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
I don't really know if its the same bug, but on my page I also have a severe bug
on my page which is about page breaks at wrong places.
Try looking at
http://www.at-haunis.de/guestbook.php?special=nocount
or
http://www.at-haunis.de/events.php?special=nocount
and try do do print preview.
It inserts a page break between the header (<h1>) and the table.
It seems somehow to be related to the font-size I define for the header in the
style sheet. Sometimes the page break disappears when I insert a <h2> header in
between. It seems to be also related to some layout parameters of the table.

Tested with
Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.3) Gecko/20030312
and other versions.

Btw. I was not able to reproduce that bug with that starwars page, maybe because
it fits on one page with my font settings.
I don't see extra page breaks with Rupert's URLs from comment 4.
(but background doesn't show in preview)
Assignee: rods → nobody
OS: Other → All
QA Contact: sujay → printing
=> WFM Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Reporter

Comment 6

11 years ago
This is very old.  I concur with closing it,
You need to log in before you can comment on or make changes to this bug.