"background-attachment: fixed" puts image underneath scrollbar when combined with background-position: top right

VERIFIED DUPLICATE of bug 46814

Status

()

Core
Layout: R & A Pos
VERIFIED DUPLICATE of bug 46814
16 years ago
16 years ago

People

(Reporter: malross, Unassigned)

Tracking

Trunk
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90; Circle0701; H010818)
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-GB; rv:0.9.4) Gecko/20011128 Netscape6/6.2.1

In the page at http://www.malross.co.uk/help/, the background image is fixed at 
the top right of the page and is intended to align nicely with the content 
appearing over it. Sadly, the use of a "fixed" background attachment puts the 
image too far to the right - underneath the scrollbar, in fact. Changing the 
background attachment to "scroll" puts it in the right place, but it's not the 
effect I'm looking for.

BTW, the stylesheet for the page is at:
http://www.malross.co.uk/help/minimal.css

Reproducible: Always

Steps to Reproduce:
1. Fire up the same browser I'm using (Netscape 6.2)
2. Go to http://www.malross.co.uk/help/

Actual Results:  
The background image was under the right-hand scrollbar

Expected Results:  
Aligned the right-hand edge of the background image with the left-hand edge of 
the vertical scrollbar, just as it does for scrolling background images.
Netscape 6.2 is way too old a build to file bugs based on, and you should
probably test a Mozilla build anyway before filing in Bugzilla.

*** This bug has been marked as a duplicate of 46814 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Verified dupe.  This has already been fixed.  Get a nightly build, or wait for
1.3beta or later.  Don't go spreading rumours (reading your blog) about what
Gecko does or doesn't do if you are using old builds.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

16 years ago
Sorry I missed the bit about "please do not file bugs on copies of Mozilla 
older than two weeks". BTW, that page was just a dummy for my own use and is 
not linked from anywhere except this incident. No-one will ever see the 
comments, as I'll trash it now. Anyway, sorry I didn't test on the latest 
version.
You need to log in before you can comment on or make changes to this bug.