PK11_GetModInfo not found

RESOLVED WORKSFORME

Status

Core Graveyard
Security: UI
--
critical
RESOLVED WORKSFORME
15 years ago
a year ago

People

(Reporter: Jan Martin, Assigned: Stephane Saux)

Tracking

Other Branch
HP
HP-UX

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US; rv:1.1) Gecko/20020828
Build Identifier: Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US; rv:1.2) Gecko/20021203

When accessing some web pages, browser crashes with this message:

/usr/lib/dld.sl: Unresolved symbol: PK11_GetModInfo (code)  from
/d2/jmm/mozilla_1.2.1/components/libpipnss.sl

Something seems to be missing.

Reproducible: Always

Steps to Reproduce:
1.go to google.com
2.enter a search string, and hit search button (or CRLF)
3.

Actual Results:  
mozilla crashes

Expected Results:  
return results of search

Comment 1

15 years ago
WFM on Win2000
Summary: PK11_GetModInfo not found → PK11_GetModInfo not found

Comment 2

15 years ago
Jan, I'm surprised there are mismatches in the version numbers. You say, your
build identifier is 1.2, but your code is trying to access libraries in a
directory for version 1.2.1?

Is possibly your shared library environment pointing to multiple Mozilla library
directories, and what you see is an effect of mixing different version executables?
PK11_GetModInfo was added to libNSS3.sl in NSS 3.6.  
I think the very latest versions of mozilla use the new features of NSS 3.6.
So, if you're using a very new mozilla and an not-very-new NSS (e.g. NSS 3.5)
that would explain it.  The solution is to get or build NSS 3.6 or 3.7 
and use it.

Submittor, please confirm that this is indeed a lib mismatch, or not.
(Reporter)

Comment 4

15 years ago
I confirm that the HPUX build marked as version 1.2.1 with filename
mozilla-hppa2.0w-hp-hpux11.00-1.2.1.tar.gz in fact says that it is
version 1.2 when you click Help->About Mozilla

I find a libnss3.sl [note lower case "nss"] in mozilla top directory,
so maybe the builder of the HPUX build used the wrong version of libnss?

Comment 5

14 years ago
1.2 is quite old by now.  Closing out bug, please reopen or file a new bug if
this happens with a more recent version.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

13 years ago
Component: Security: UI → Security: UI
Product: PSM → Core
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.