Address book lists fail if any one card has an invalid (blank) email.

VERIFIED DUPLICATE of bug 192944

Status

SeaMonkey
MailNews: Address Book & Contacts
VERIFIED DUPLICATE of bug 192944
15 years ago
13 years ago

People

(Reporter: Richard Neill, Assigned: racham)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

If you drag many cards into a mailing list, then they must all have correct
email addresses. If any one of them has the email field left blank, many weird
errors occur.

Reproducible: Always

Steps to Reproduce:
Create a mailing list with drag and drop. One of your cards should have an
invalid or blank email address field.
Actual Results:  
Several weird errors. These included:
- Some of the mailing list cards disappeared when the list was viewed (although
they are still there if you look at the list as if it were a card in the main
address book.

- The mailing list became non-editable

- On attmpting to post to it, I got the error "Mail server responded: invalid
recipient". Not very helpful - Moz could at least have told me *which* was the
invalid recipient!


Expected Results:  
Flagged up the fact that an email address in a mailing list was null!
Then it should skip the offending card.

This caused me several errors. Some of them look suspiciosly simlar in symptom
to bugs 168543, 176413,181645

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 192944 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.