Status

()

Core
DOM: CSS Object Model
--
minor
RESOLVED DUPLICATE of bug 132592
16 years ago
16 years ago

People

(Reporter: Danai Sae-Han, Assigned: jst)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

In the top left corner of http://www.meyerweb.com/eric/css/edge/menus/demo.html
there is a small menu driven completely by CSS.  I can see all the items, but I
can't click on the hypertag links (for example "Pure CSS popups").

I am currently using Mozilla-snapshot with Build ID 2002121213 in a
Debian/testing environment, using the technique of "pinning" (=installinging a
few packages from the unstable tree in a testing environment).

Reproducible: Always

Steps to Reproduce:
1. go to http://www.meyerweb.com/eric/css/edge/menus/demo.html
2. hover over css/edge
3. go through the menu and try to click on an item

Actual Results:  
Nothing, and that's the worrying part.  ;-)

Expected Results:  
Opened the link.

Comment 1

16 years ago
dupe of "onMouseOut triggered by mouse click prevents menu from working"

*** This bug has been marked as a duplicate of 132592 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
This has, imho, nothing to do with JavaScript, since this uses *only* CSS2 for
the menu's, not one single JS code.

Note that both the upper left menu as well as the right menu have this problem
with the <li> items.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

16 years ago
wfm using build 20030105 on Win2k.

Comment 4

16 years ago
Danai: bug 132592 can occur with both CSS and JS menus.  Mozilla's underlying
mouse handling seems to be the same.

The fact that it works on Windows is more evidence of bug 132592 (it only
happens on Linux)
(Reporter)

Comment 5

16 years ago
Indeed, I have tried Mozilla build 20021212 on Windows 2000 Professional and the
browser shows no problems at all (and the editor as well).

*** This bug has been marked as a duplicate of 132592 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.