Dual display. Chimera window on secondary display does only paint the area which "fits" on the primary display

RESOLVED DUPLICATE of bug 159552

Status

defect
RESOLVED DUPLICATE of bug 159552
17 years ago
17 years ago

People

(Reporter: ravn, Assigned: bryner)

Tracking

Details

Reporter

Description

17 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030102 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030102 Chimera/0.6+

I have a dual display configuration with the primary display the normal
1152x768, and the secondary display 1280x1024.

When a Chimera window is maximised on the secondary display, the repainting is
incorrect, as it only repaints an area suitable for a maximised window on the
primary display.

The effect is having an grey area on the right and lower part of the window. 
This border is considered part of the window, and scrolled along with the rest
if using the scroll bars.  Mozilla 1.2 does not have this problem.



Reproducible: Always

Steps to Reproduce:
1. Use dual display Mac
2. Move Chimera to secondary display, and maximize
3. Open any webpage and see that the page is not rendered to the full page.

Actual Results:  
insufficient repaint of page.

Expected Results:  
painted the complete page.

Let me know if you need a screen dump to see this.

Comment 1

17 years ago
Duplicate of bug 159552.

Comment 2

17 years ago
Yep, definitely a dupe of the indicated bug. Resolving as such.

*** This bug has been marked as a duplicate of 159552 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.