Form not submitting, it redraws the page instead of calling action URL.

RESOLVED DUPLICATE of bug 147558

Status

()

Core
Layout: Tables
P3
normal
RESOLVED DUPLICATE of bug 147558
16 years ago
14 years ago

People

(Reporter: tonio caputo, Unassigned)

Tracking

({testcase})

Trunk
Future
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

In the example:

  If you click the OK or CANCEL button for the first time instead
of submitting the form it redraws the form.

  When you click the OK or CANCEL button for second time the
form is submitted correctly


Reproducible: Always

Steps to Reproduce:
1.Load the page in Additional Information
2.Click OK button once (the page is redrawn)
3.Click OK button again (the form is submitted)

Actual Results:  
In step 2 instead of submitting a form the page is redrawn.

Expected Results:  
In step 2 the form must be submitted

<html>
<head><title>Dialog windows</title></head>
<body>

<!-- if you put the width attribute to this TABLE-TAG 
     it works properly
     Ex.: <table cellpadding="0" cellspacing="0" border="0" width="20%">
-->
<table cellpadding="0" cellspacing="0" border="0">
<tbody>

<!-- Dialog title -->
<tr>
  <td>
    <div style="border: 1px solid #000000; padding: 2px; background: #999999;">
    <form method="post" action="en1">

	  <input type="submit" name="CLOSE_DIALOG" value="X">
	  Title
    </form>
    </div>
 </td>
</tr>


<!-- Dialog body -->
<tr>
  <td>
    <div style="border: 1px solid #000000; padding: 2px; background: #eeeeee">

    <form method="post" action="en3">
	Input name
	<input type="text" size="12" maxlength="50">
	<hr>
	<input type="submit" name="CONFIRM" value="OK">
	&nbsp;
	<input type="submit" name="CANCEL" value="Cancel">
    </form>
    </div>

</td>
</tr>

</tbody>
</table>

</body>
</html>

Comment 1

16 years ago
Created attachment 110591 [details]
submit button redraw box instead submit

I simplify the code a bit. It seems than <div> with border-style: solid inside
<table> is cause of such behaviour.
This is a table reflow bug, not a form submission bug...
Assignee: alexsavulov → table
Status: UNCONFIRMED → NEW
Component: Form Submission → Layout: Tables
Ever confirmed: true
QA Contact: vladimire → amar

Updated

16 years ago
Keywords: testcase

Updated

15 years ago
Priority: -- → P3
Target Milestone: --- → Future

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 147558 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.