Closed Bug 18757 Opened 20 years ago Closed 20 years ago

Bad HTML causes frames not to render. Frames render in Nav.

Categories

(Core :: Layout, defect, P3)

x86
All
defect

Tracking

()

VERIFIED DUPLICATE of bug 18928

People

(Reporter: christinehoff4, Assigned: rickg)

References

()

Details

Attachments

(3 files)

Using build 1999111016 on Win 95.

Steps to Reproduce:
1. Open the above URL (Musee d'Orsay).
2. Click on 'Collections'. Page consists of 2 frames.

Actual result: Frames do not load - what renders is the index page with some
text.
Expected result: Frames should load.

This behavior is across platform.

Problem: There is an illegal <p> tag preceding the <frameset> tag. Remove that
<p> tag and the frames load.

Nav renders the frames with the bad HTML.

Attached is a simplified test case.
Attached file Top frame
Attached file Bottom Frame
QA Contact: petersen → chrisd
If simplified test case can't be reach from the attachments, here is the
internal address:

http://slip/projects/marvin/bugs/main3.html
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 18928 ***
Status: RESOLVED → VERIFIED
Verifying bug a dup of #18928. Why was a new bug written up and then this one
marked a dup?
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.