If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[BLOCK] Form for uploading files do center

VERIFIED WORKSFORME

Status

()

Core
Layout
P3
normal
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Charles Mak, Assigned: buster)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Overview Description: Form for uploading files do center

Steps to Reproduce:
1) goto the test case
2) notice that the textfield along with the browse button is not being centered.

Actual Results: Textfield of type file is not being centered

Expected Results: It should be centered

Build Date & Platform Bug Found: build 1999-1112-08 on Windows NT 4.0 (sp6)

Additional Builds and Platforms Tested On: none

Additional Information: none
(Reporter)

Comment 1

18 years ago
Created attachment 2842 [details]
Test Case

Updated

18 years ago
Assignee: karnaze → kmcclusk

Comment 2

18 years ago
Reassigning to Kevin.

Comment 3

18 years ago
Valid bug. The test case is displayed correctly using IE 5 on Windows 98, but
not on the 1999110108 build of Mozilla.

Updated

18 years ago
Assignee: kmcclusk → rods
Rod, any ideas on this?

Updated

18 years ago
Assignee: rods → troy
Component: Form Submission → Layout

Comment 5

18 years ago
The FileControlFrame is derived from an nsAreaFrame. It sets itself to be
"shrink wrapped" in the constructor:

  SetFlags(NS_BLOCK_SHRINK_WRAP);

Then uses the nsAreaFrame's reflow to layout its two frames (the text and the
button).

Below is part of the frame dump. Note that the button is 1230 twips and the text
is 2535 twips for a total of 3765 twips, yet it lays out as 6352 twips. It does
appear to be shrink wrapping. The FileControlFrame is centered it just doesn't
appear to be shrink wrapping correctly.

FileControl(input)(0)@014FBD30 next=014FF870 {1294,0,6352,390} [state=00010034]
sc=014FB6E0(i=1,b=0)<
  line 014F87F0: count=2 state=inline,,,[0x400] {0,0,6352,390} <
    TextControl(input)(-1)@014FAD50 {2587,15,2535,360} [state=00000034]<
    >
    <
      Block(-1)@01E9AD40 {30,30,2475,300} [state=00080405] sc=01E9AA70(i=1,b=0)<
        line 01E9A380: count=1 state=inline,,,[0x200] {0,0,1237,0} <
          Text(-1)@01E9A8A0[0,0,T]  {1237,0,0,0} [state=40000004] sc=01E9A580<
            ""
          >
        >
      >
    >
    ButtonControl(input)(-1)@014FAA70 {5122,30,1230,360} [state=00000024]
sc=014FC460<
      Area(input)(-1)@014FDE30 {205,60,1140,270} [state=00090405]
sc=014FD800(i=1,b=0)<
        line 014FE4F0: count=1 state=inline,,,[0x200] {0,0,982,240} <
          Inline(input)(-1)@014FE0B0 {157,0,825,240} [state=00000044]
sc=014FD1D0<
            Text(-1)@014FBE80[0,9,T]  {0,0,825,240} [state=40000004]
sc=014FE540<
              "Browse..."
            >
          >
        >
      >
    >
  >
>

Reassigning to Troy.
Also, changed component to "Layout"

Updated

18 years ago
Assignee: troy → kipp

Comment 6

18 years ago
I don't know why it's an area frame, but it probably shouldn't be. It probably
should just be a block frame.

The area frame doesn't deal with shrink wrapping, it just handles being a
containing block for absolutely positioned child elements

This would seem to just be a block issue.

Comment 7

18 years ago
Updating to default Layout Assignee...kipp no longer with us :-(

Comment 8

18 years ago
Why are you re-reassing layout bugs? Do NOT touch layout bugs.

The bugs are assigned to Kipp so they can stay neatly organized until we have a
new owner for the block/inline code.
(Assignee)

Comment 9

18 years ago
mass moving all Kipp's pre-beta bugs to M15.  Nisheeth and I will
prioritize these and selectively move high-priority bugs into M13 and M14.
(Assignee)

Updated

18 years ago
Summary: Form for uploading files do center → [BLOCK] Form for uploading files do center
(Assignee)

Comment 10

18 years ago
mine! mine mine mine!  all mine!  whoo-hoo!
Assignee: kipp → buster
(Reporter)

Comment 11

18 years ago
it looks like this problem's been fixed on 2000-0312-08 winNT (sp6). my testcase 
looks fine now.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 12

18 years ago
reporter marked wfm, stamping verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.