Location bar search impossible after invalid URL

RESOLVED DUPLICATE of bug 135363

Status

SeaMonkey
Search
--
minor
RESOLVED DUPLICATE of bug 135363
16 years ago
10 years ago

People

(Reporter: Magnus Gunnarsson, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130

Sometimes I type some words (e.g. 'digital camera') in the loaction bar with the
purpose of searching for them in Google, but forget to hit down-arrow before I
hit enter. The result is that the Browser tries to locate a server called
'digital camera' or possibly 'www.digital camera.com'. So far no problem. But
when I try to correct my mistake by placing the cursor in the location filed
again and hitting down-arrow a couple of times to select "Search Google for
'digital camera'" I get the same error message as before, 'The URL is not valid
andcannot be loaded.'. 

Reproducible: Always

Steps to Reproduce:
1. Type 'digital camera' in the location bar.
2. Hit the enter key.
3. Accept the error message.
4. Place the cursor at the location bar again, and hit down-arrow a couple of
times to select 'Search xxx for 'digital camera', and hit enter. 

Actual Results:  
The error message about invalid URL appears.

Expected Results:  
Passed the search terms on to the search engine (Google, in my case) and
displayed the results.

I write this on a MacOS X 10.1 machine, but the bug is there also on the Win
2000 machine I have at work.

Comment 1

16 years ago
This was fixed on 10-Dec-2002 by bug 135363.
Please reopen if you still see it with a current build.

*** This bug has been marked as a duplicate of 135363 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.