Closed Bug 187590 Opened 18 years ago Closed 18 years ago

Save as Web Page, complete does not transform url in an included *.css to local url

Categories

(Core Graveyard :: File Handling, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 115107

People

(Reporter: cfsl, Assigned: law)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030102
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030102

In http://www.lwl.org/landschafts-und-baukultur/shop/blb_003/bielefld.html the
css file formate.css is included. formate.css declares the form of the bullet
point to be "ul { list-style-image:url(grafic/anlage2.gif);
list-style-position:outside; line-height:16pt; }".

As I chose "Save as.. / Web Page, complete" the resulting formate.css rested
unchanged regarding the ul declaration and the gif-file was not locally saved at
all. I expected a download of anlage2.gif and a replacement of
"grafic/anlage2.gif" according to the local storage.


Reproducible: Always

Steps to Reproduce:
1. open http://www.lwl.org/landschafts-und-baukultur/shop/blb_003/bielefld.html
2. select "File / Save as ..."
3. choose as type "Web Page, complete"
4. choose an arbitrary file name
5. click "save"
6. open a new tab
7. select "File / Open File ..."
8. open the just saved file
9. open with a text editor the file formate.css in the according "* files"
directory that was established as you saved the Page in step 5.

Actual Results:  
1. The list had a default bullet point.
2. anlage2.gif was not downloaded
3. in formate.css was no local url for anlage2.gif

Expected Results:  
1. The list shown in the browser should use the original bullet point (anlage2.gif)
2. anlage2.gif should have been transfer to my hard disk
3. in formate.css should have been a local url

*** This bug has been marked as a duplicate of 115107 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.