SecretDecoderRing.KeyManager doesn't check for null pointers

RESOLVED DUPLICATE of bug 202183

Status

JSS
Library
RESOLVED DUPLICATE of bug 202183
15 years ago
15 years ago

People

(Reporter: Jamie Nicolson, Assigned: Jamie Nicolson)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

15 years ago
KeyManager blindly accepts pointers that it is given and passes them down to C
code, where they cause a crash.  KeyManager should check pointers for null and
throw a NullPointerException.
(Assignee)

Comment 1

15 years ago
Created attachment 110613 [details] [diff] [review]
proposed patch

With this patch, we check all variables that will get passed to C code for
null, and throw a NullPointerException.
(Assignee)

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 202183 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.