Closed Bug 1876341 Opened 5 months ago Closed 5 months ago

Update PDF.js to new version ae627870801eb758180e1db0c51b5a778c61af7a from 2024-01-23 18:00:28

Categories

(Firefox :: PDF Viewer, enhancement)

enhancement

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox124 --- affected

People

(Reporter: update-bot, Assigned: calixte)

References

(Blocks 1 open bug)

Details

(Whiteboard: [3pl-filed][task_id: ZxIiq1RQSj6BuuLObBvnzw])

Attachments

(1 obsolete file)

This update covers 29 commits. Here are the overall diff statistics, and then the commit information.


toolkit/components/pdfjs/content/PdfJsDefaultPreferences.sys.mjs | 56 +-
toolkit/components/pdfjs/content/build/pdf.mjs | 1085 +++++++--
toolkit/components/pdfjs/content/build/pdf.sandbox.external.sys.mjs | 228 +-
toolkit/components/pdfjs/content/build/pdf.scripting.mjs | 99 +-
toolkit/components/pdfjs/content/build/pdf.worker.mjs | 374 +-
toolkit/components/pdfjs/content/web/viewer-geckoview.css | 32 +-
toolkit/components/pdfjs/content/web/viewer-geckoview.mjs | 99 +-
toolkit/components/pdfjs/content/web/viewer.css | 56 +-
toolkit/components/pdfjs/content/web/viewer.mjs | 99 +-
toolkit/components/pdfjs/moz.yaml | 4 +-
10 files changed, 1329 insertions(+), 803 deletions(-)


f724ae98a1c0859885083448e2cbc3f3d4c31cf1 by Nicolò Ribaudo

https://github.com/mozilla/pdf.js/commit/f724ae98a1c0859885083448e2cbc3f3d4c31cf1
Authored: 2024-01-22 18:33:31 +0100
Committed: 2024-01-23 16:00:59 +0100

Replace the webpack+acorn transform with a Babel plugin

This commit converts the pdfjsdev-loader transform into a Babel plugin,
to skip a AST->string->AST round-trip.

Before this commit, the webpack build process was:

  1. Babel parses the code
  2. Babel transforms the AST
  3. Babel generates the code
  4. Acorn parses the code
  5. pdfjsdev-loader transforms the AST
  6. @javascript-obfuscator/escodegen generates the code
  7. Webpack parses the file
  8. Webpack concatenates the files

After this commit, it is reduced to:

  1. Babel parses the code
  2. Babel transforms the AST
  3. babel-plugin-pdfjs-preprocessor transforms the AST
  4. Babel generates the code
  5. Webpack parses the file
  6. Webpack concatenates the files

This change improves the build time by ~25% (tested on MacBook Air M2):

  • gulp lib: 3.4s to 2.6s
  • gulp dist: 36s to 29s
  • gulp generic: 5.5s to 4.0s
  • gulp mozcentral: 4.7s to 3.2s

The new Babel plugin doesn't support the saveComments option of
pdfjsdev-loader, and it just always discards comments. Even though
pdfjsdev-loader supported multiple values for that option, it was
effectively ignored due to acorn dropping comments by default.

Files Deleted:

  • external/webpack/pdfjsdev-loader.mjs

Files Modified:

  • external/builder/babel-plugin-pdfjs-preprocessor.mjs
  • external/builder/fixtures_esprima/blocks-expected.js
  • external/builder/fixtures_esprima/comments-expected.js
  • external/builder/fixtures_esprima/constants-expected.js
  • external/builder/fixtures_esprima/deadcode-expected.js
  • external/builder/fixtures_esprima/deadcode.js
  • external/builder/fixtures_esprima/evals-expected.js
  • external/builder/fixtures_esprima/evals.json
  • external/builder/fixtures_esprima/ifs-expected.js
  • external/builder/fixtures_esprima/importalias-expected.js
  • external/builder/test-fixtures.mjs
  • external/builder/test-fixtures_esprima.mjs
  • gulpfile.mjs
  • package-lock.json
  • package.json

f5bb9bc21bbcfb8fbc125254fcf64cc6d7ad5ee2 by Nicolò Ribaudo

https://github.com/mozilla/pdf.js/commit/f5bb9bc21bbcfb8fbc125254fcf64cc6d7ad5ee2
Authored: 2024-01-23 13:05:01 +0100
Committed: 2024-01-23 13:13:43 +0100

Rename preprocessor2.mjs to babel-plugin-pdfjs-preprocessor.mjs

This is in preparation for the next commit, which will convert
preprocessor2.mjs to a Babel plugin. The purpose of this commit
is to help git track the rename regardless of the large amount
of changes.

Files Changed:

  • R100 external/builder/preprocessor2.mjs

fa583427eff9f453fba0c836e660e70c6db706ae by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/fa583427eff9f453fba0c836e660e70c6db706ae
Authored: 2024-01-22 13:06:32 +0100
Committed: 2024-01-22 13:06:32 +0100

Always export the "raw" /ToUnicode-data from PartialEvaluator.preEvaluateFont (PR 13354 follow-up)

This, ever so slightly, simplifies the implementation in the PartialEvaluator.extractDataStructures-method.

Files Modified:

  • src/core/evaluator.js

f21a30dfb4c7812e4b31acbb15206f24611ae58b by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/f21a30dfb4c7812e4b31acbb15206f24611ae58b
Authored: 2024-01-22 12:44:32 +0100
Committed: 2024-01-22 12:47:06 +0100

Convert the PartialEvaluator.readToUnicode method to be async

Files Modified:

  • src/core/evaluator.js

f5c01188dc8fbb586664bf68ef492c26813d5253 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/f5c01188dc8fbb586664bf68ef492c26813d5253
Authored: 2024-01-22 12:22:48 +0100
Committed: 2024-01-22 12:47:06 +0100

Convert the PartialEvaluator.extractDataStructures method to be async

Files Modified:

  • src/core/evaluator.js

cf0797dfbd7fe1f7dcd9f1d4e60848a3a2a5de19 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/cf0797dfbd7fe1f7dcd9f1d4e60848a3a2a5de19
Authored: 2024-01-22 12:17:20 +0100
Committed: 2024-01-22 12:47:06 +0100

Use await consistently in the PartialEvaluator.setGState method

Files Modified:

  • src/core/evaluator.js

1cc83c4fdc614c41cf314296cf0160693c9b60da by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/1cc83c4fdc614c41cf314296cf0160693c9b60da
Authored: 2024-01-22 12:14:30 +0100
Committed: 2024-01-22 12:47:06 +0100

Use await consistently in the PartialEvaluator.buildFormXObject method

Files Modified:

  • src/core/evaluator.js

06601fd90c0e9b74d1f7ae18517f19680b93772d by Calixte Denizet

https://github.com/mozilla/pdf.js/commit/06601fd90c0e9b74d1f7ae18517f19680b93772d
Authored: 2024-01-21 23:00:43 +0100
Committed: 2024-01-22 10:48:00 +0100

Print correctly documents containing chars with an unicode greater than 0xFFFF (bug 1669097)

Files Added:

Files Modified:

  • src/core/annotation.js
  • src/core/core_utils.js
  • src/core/default_appearance.js
  • test/pdfs/.gitignore
  • test/test_manifest.json

d7e41d4cb6fe42d1b7a6388eb1328792f12de883 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/d7e41d4cb6fe42d1b7a6388eb1328792f12de883
Authored: 2024-01-21 19:50:06 +0100
Committed: 2024-01-21 19:59:13 +0100

Ensure that EvaluatorPreprocessor.opMap has a null-prototype (issue 17554)

This accidentally regressed in PR 16956, sorry about that!

Files Added:

  • test/pdfs/issue17554.pdf

Files Modified:

  • src/core/evaluator.js
  • test/pdfs/.gitignore
  • test/test_manifest.json

6dd77b3c140dcba30289766354076facb3c0bc6d by Tim van der Meij

https://github.com/mozilla/pdf.js/commit/6dd77b3c140dcba30289766354076facb3c0bc6d
Authored: 2024-01-21 18:49:55 +0100
Committed: 2024-01-21 19:37:13 +0100

Don't ignore test.mjs child process exit codes in the Gulpfile

In the Gulpfile only the exit codes of test.mjs child processes
erroneously aren't checked. This causes failures in test.mjs to be
logged but not propagated to the master process, which in turn causes
test runners such as GitHub Actions to succeed because they only
monitor the master process. This is easy to reproduce by throwing an
error at the top of test.mjs and running gulp makeref or gulp unittest: the error is logged, but the task that spawned the child
process succeeds and the master process exits with exit code 0. This is
problematic because it can easily cause errors to go by unnoticed.

This commit fixes the issue by making sure that the test.mjs
invocations are handled in the same way as the other child processes
in the file, i.e., if the child process exits with a non-zero exit code
then the master process also exits with a non-zero exit code. After this
patch the error is still logged, but the task now also fails and the
master process exits with exit code 1 to properly signal failure.

Files Modified:

  • gulpfile.mjs

3c2c0ecd8851bf59c49796251d50c3863d0cb2d2 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/3c2c0ecd8851bf59c49796251d50c3863d0cb2d2
Authored: 2024-01-21 17:41:25 +0100
Committed: 2024-01-21 17:42:33 +0100

Use the ESLint arrow-body-style rule in more spots in src/core/evaluator.js

Files Modified:

  • src/core/evaluator.js

d1bef8cb8660a5da1e250ed4888c3b8f7779bd4a by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/d1bef8cb8660a5da1e250ed4888c3b8f7779bd4a
Authored: 2024-01-21 17:36:50 +0100
Committed: 2024-01-21 17:36:50 +0100

Use await consistently in the PartialEvaluator.translateFont method

Files Modified:

  • src/core/evaluator.js

fc62eec9017721af1dae51336a1190223ba37008 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/fc62eec9017721af1dae51336a1190223ba37008
Authored: 2024-01-21 17:32:05 +0100
Committed: 2024-01-21 17:32:05 +0100

Convert the handleSetFont methods, in src/core/evaluator.js, to be async

Files Modified:

  • src/core/evaluator.js

f9a384d711c49011737cfb1e303f3a40a2cae991 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/f9a384d711c49011737cfb1e303f3a40a2cae991
Authored: 2024-01-21 15:47:39 +0100
Committed: 2024-01-21 16:20:55 +0100

Enable the arrow-body-style ESLint rule

This manually ignores some cases where the resulting auto-formatting would not, as far as I'm concerned, constitute a readability improvement or where we'd just end up with more overall indentation.

Please see https://eslint.org/docs/latest/rules/arrow-body-style

Files Modified:

  • .eslintrc
  • src/core/annotation.js
  • src/core/catalog.js
  • src/core/document.js
  • src/core/evaluator.js
  • src/core/xfa/utils.js
  • src/display/annotation_layer.js
  • src/display/api.js
  • src/display/canvas.js
  • src/display/display_utils.js
  • src/display/editor/tools.js
  • src/display/node_utils.js
  • src/shared/util.js
  • test/driver.js
  • test/integration/highlight_editor_spec.mjs
  • test/integration/test_utils.mjs
  • test/unit/api_spec.js
  • test/unit/scripting_spec.js
  • web/pdf_document_properties.js
  • web/pdf_find_controller.js

998184a00ea6c940d75c14e28349b611eab9058e by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/998184a00ea6c940d75c14e28349b611eab9058e
Authored: 2024-01-21 15:45:28 +0100
Committed: 2024-01-21 15:45:28 +0100

Remove the no-confusing-arrow ESLint rule since it's deprecated

Please see https://eslint.org/docs/latest/rules/no-confusing-arrow

Files Modified:

  • .eslintrc

9dfe9c552c372c44e3af27b8749d2ec4acccdbbd by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/9dfe9c552c372c44e3af27b8749d2ec4acccdbbd
Authored: 2024-01-21 10:13:12 +0100
Committed: 2024-01-21 10:13:12 +0100

Use shorter arrow functions where possible

For arrow functions that are both simple and short, we can avoid using explicit return to shorten them even further without hurting readability.

For the gulp mozcentral build-target this reduces the overall size of the output by just under 1 kilo-byte (which isn't a lot but still can't hurt).

Files Modified:

  • src/core/annotation.js
  • src/core/cmap.js
  • src/core/fonts.js
  • src/core/writer.js
  • src/display/api.js
  • src/display/display_utils.js
  • src/display/fetch_stream.js
  • src/display/network.js
  • src/display/node_stream.js
  • src/pdf.sandbox.js
  • src/scripting_api/util.js
  • test/integration/freetext_editor_spec.mjs
  • test/unit/api_spec.js
  • test/unit/cff_parser_spec.js
  • test/unit/message_handler_spec.js
  • test/unit/node_stream_spec.js
  • test/unit/pdf_find_controller_spec.js
  • test/unit/scripting_spec.js
  • web/app.js
  • web/pdf_link_service.js
  • web/pdf_scripting_manager.component.js
  • web/ui_utils.js

99ee308f3d9fa8d29444a9bb783f604f70424c52 by Calixte Denizet

https://github.com/mozilla/pdf.js/commit/99ee308f3d9fa8d29444a9bb783f604f70424c52
Authored: 2024-01-20 21:42:37 +0100
Committed: 2024-01-20 22:10:42 +0100

Avoid to have focused tests in using eslint-plugin-jasmine

Files Modified:

  • package-lock.json
  • package.json
  • test/.eslintrc

0cca9a02404a15ad7b5f60567792e77bd7544cc1 by Calixte Denizet

https://github.com/mozilla/pdf.js/commit/0cca9a02404a15ad7b5f60567792e77bd7544cc1
Authored: 2024-01-19 16:04:02 +0100
Committed: 2024-01-20 21:57:54 +0100

[Editor] Don't add the keyboard listener on the color-picker each time the dropdown menu is shown

and display/hide the dropdown menu when pressing arrow keys.

Files Modified:

  • src/display/editor/color_picker.js
  • test/integration/highlight_editor_spec.mjs

c70edbced7212e086625af1cbfce6ec4e6a21088 by Tim van der Meij

https://github.com/mozilla/pdf.js/commit/c70edbced7212e086625af1cbfce6ec4e6a21088
Authored: 2024-01-20 19:58:02 +0100
Committed: 2024-01-20 20:05:08 +0100

Remove DNS resolver workaround from the test framework

The if statement is no longer necessary because the Node.js versions
that didn't provide dns.setDefaultResultOrder are no longer supported,
but looking into this a bit more it turns out that the entire workaround
is no longer necessary because the issue got fixed in Firefox 105 in bug
1769994. Indeed, Firefox now starts nicely with the workaround removed.

Reverts 60ed3cd297c4045b90f4114a74e5baa4ef1c5056.

Files Modified:

  • test/test.mjs

c9755bdbc860605c70d4f75993f46a705d9365f4 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/c9755bdbc860605c70d4f75993f46a705d9365f4
Authored: 2024-01-20 11:56:29 +0100
Committed: 2024-01-20 12:01:23 +0100

Ignore auto-formatting patches in git blame

When using Prettier to auto-format (parts of) the code-base you usually end up with huge patches that touch lots of lines without making any actual changes.
This often adds unnecessary steps when using git blame, however it's easy enough to avoid this; please refer to https://docs.github.com/en/repositories/working-with-files/using-files/viewing-a-file#ignore-commits-in-the-blame-view

Files Added:

  • .git-blame-ignore-revs

2dd6910aa4e38a58a8937358e38725c1fdf16fc3 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/2dd6910aa4e38a58a8937358e38725c1fdf16fc3
Authored: 2024-01-20 09:54:21 +0100
Committed: 2024-01-20 09:54:21 +0100

Update l10n files

Files Modified:

  • l10n/cy/viewer.ftl
  • l10n/dsb/viewer.ftl
  • l10n/el/viewer.ftl
  • l10n/es-CL/viewer.ftl
  • l10n/es-ES/viewer.ftl
  • l10n/eu/viewer.ftl
  • l10n/fr/viewer.ftl
  • l10n/fy-NL/viewer.ftl
  • l10n/gn/viewer.ftl
  • l10n/hu/viewer.ftl
  • l10n/is/viewer.ftl
  • l10n/nl/viewer.ftl
  • l10n/pt-BR/viewer.ftl
  • l10n/skr/viewer.ftl
  • l10n/sl/viewer.ftl
  • l10n/tr/viewer.ftl

a5a9357e1512af1fc2fa5f598c666629362e966b by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/a5a9357e1512af1fc2fa5f598c666629362e966b
Authored: 2024-01-20 09:40:33 +0100
Committed: 2024-01-20 09:52:57 +0100

Update npm packages

Files Modified:

  • .prettierrc
  • package-lock.json
  • package.json

5732c0c54ae825c489feac65dfa88c11fc37fce2 by Calixte Denizet

https://github.com/mozilla/pdf.js/commit/5732c0c54ae825c489feac65dfa88c11fc37fce2
Authored: 2024-01-19 17:47:05 +0100
Committed: 2024-01-19 22:13:51 +0100

Use the original value of a field when propagating event (fixes #17540)

And avoid to not format a field when the value is 0.

Files Added:

  • test/pdfs/issue17540.pdf

Files Modified:

  • src/scripting_api/aform.js
  • src/scripting_api/event.js
  • test/integration/scripting_spec.mjs
  • test/pdfs/.gitignore
  • test/unit/scripting_spec.js

f3b76f5ae299eac332b9de89d26e3592e0d5e50a by Calixte Denizet

https://github.com/mozilla/pdf.js/commit/f3b76f5ae299eac332b9de89d26e3592e0d5e50a
Authored: 2024-01-19 20:16:55 +0100
Committed: 2024-01-19 20:16:55 +0100

[Editor] Unselect highlights when the user click on the text layer (bug 1869767)

Files Modified:

  • src/display/editor/annotation_editor_layer.js
  • test/integration/highlight_editor_spec.mjs

b37536c38c3bee8dc3784d8f58dfd1b0cc170cf0 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/b37536c38c3bee8dc3784d8f58dfd1b0cc170cf0
Authored: 2024-01-19 14:10:52 +0100
Committed: 2024-01-19 14:10:52 +0100

Remove the isArrayBuffer helper function

This old helper function can now be replaced with ArrayBuffer.isView() and/or instanceof ArrayBuffer checks, as needed depending on the situation.

Files Modified:

  • src/display/api.js
  • src/shared/murmurhash3.js
  • src/shared/util.js
  • test/unit/util_spec.js

a1bf12537c7181effb101a8c4c328d9d0e9cd6ed by Calixte Denizet

https://github.com/mozilla/pdf.js/commit/a1bf12537c7181effb101a8c4c328d9d0e9cd6ed
Authored: 2024-01-18 22:38:42 +0100
Committed: 2024-01-19 13:02:11 +0100

[Editor] Change the arrow direction when the dropdown is visible in the color picker (bug 1875357)

and hide the dropdown when the user click outside of the color picker.

Files Modified:

  • src/display/editor/color_picker.js
  • test/integration/highlight_editor_spec.mjs
  • web/annotation_editor_layer_builder.css

d64f334f98d4b7f1c2e09a731a63b68629c946f9 by Calixte Denizet

https://github.com/mozilla/pdf.js/commit/d64f334f98d4b7f1c2e09a731a63b68629c946f9
Authored: 2024-01-17 16:42:35 +0100
Committed: 2024-01-19 12:58:46 +0100

[Editor] Add support for printing/saving free highlight annotations

Files Modified:

  • src/core/annotation.js
  • src/core/writer.js
  • src/display/editor/highlight.js
  • src/display/editor/outliner.js
  • test/test_manifest.json
  • test/unit/annotation_spec.js

83c78dbfa8f2f532b22ba10cebca2a67c0fac8ef by Calixte Denizet

https://github.com/mozilla/pdf.js/commit/83c78dbfa8f2f532b22ba10cebca2a67c0fac8ef
Authored: 2024-01-18 18:36:03 +0100
Committed: 2024-01-18 19:44:21 +0100

Make the caret visible in the text layer in caret browsing mode

In order to do that we must change the text layer opacity to 1 but
it has several implications:

  • the selection color must have an alpha component,
  • the background color of the span used for highlighted words
    must have an alpha component either, but now the opacity is 1
    we can use some backdrop-filters in HCM making the highlighted
    words more visible.
  • fix a regression caused by #17196: the css variable --hcm-highlight-filter
    has to live under the #viewer element because in HCM it's overwritten
    by js at this level, hence links annotations for example didn't
    have the right colors when hovered.

Files Modified:

  • src/display/base_factory.js
  • src/display/display_utils.js
  • web/annotation_layer_builder.css
  • web/pdf_page_view.js
  • web/pdf_viewer.css
  • web/pdf_viewer.js
  • web/text_layer_builder.css

8fbfef0c0792da5ae057c8c7851e1ccb3f6e83fe by Calixte Denizet

https://github.com/mozilla/pdf.js/commit/8fbfef0c0792da5ae057c8c7851e1ccb3f6e83fe
Authored: 2024-01-12 19:49:15 +0100
Committed: 2024-01-18 16:26:04 +0100

[Editor] Add the ability to make a free highlight (i.e. without having to select some text) (bug 1856218)

The free highlighting is enabled when the mouse pointer isn't on some text.
Then we draw a shape with smoothed borders corresponding to the movement of
the mouse.
Printing/saving and changing the thickness will come later.

Files Modified:

  • src/display/draw_layer.js
  • src/display/editor/annotation_editor_layer.js
  • src/display/editor/highlight.js
  • src/display/editor/outliner.js
  • web/annotation_editor_layer_builder.css
  • web/draw_layer_builder.css
  • web/text_layer_builder.css

Assignee: nobody → update-bot
Status: NEW → ASSIGNED

The try push is done, we found jobs with unclassified failures.

Known Issues (From Push Health):

  • toolkit/components/pdfjs/test/browser_pdfjs_download_button.js
    • 1 of 4 failed on the same (retriggered) task
      - test-macosx1015-64-qr/debug-mochitest-browser-chrome-1 (OQ5e_Dk2SCuyblRyJ7_YsQ)

Known Issues (From Taskcluster):

  • test-linux1804-64-qr/opt-mochitest-browser-chrome-spi-nw-1 (U-P0-BO5QIODySalr-FOjA) - new failure not classified
  • test-windows11-32-2009-qr/opt-mochitest-browser-chrome-1 (HPq2DeLoRmOdx4TMLcKblg) - new failure not classified
  • test-windows11-64-2009-qr/opt-mochitest-browser-chrome-1 (CxhDutiXRxO4iHvGfXvSLA) - new failure not classified
  • test-windows11-64-2009-qr/opt-mochitest-browser-chrome-spi-nw-1 (H8YMFOkrTe-BBA5OatDBaA) - new failure not classified
  • test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-1 (fRUUrAHqQFiEEyKRCvt0IA) - new failure not classified
  • test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-a11y-checks-1 (HTudU6z5SYy4bjdfQeUFPA) - new failure not classified
  • test-macosx1015-64-qr/opt-mochitest-browser-chrome-spi-nw-1 (WJclUy5tSCSDgcUaWAp18g) - new failure not classified
  • test-macosx1015-64-qr/opt-mochitest-browser-chrome-1 (RrDYuoh_TQKKExP1SfK7Iw) - new failure not classified
  • test-macosx1015-64-qr/debug-mochitest-browser-chrome-1 (OQ5e_Dk2SCuyblRyJ7_YsQ) - new failure not classified

Needs Investigation (From Push Health):

  • browser/base/content/test/static/browser_parsable_css.js
    • 8 of 8 failed on different tasks
      - test-windows11-32-2009-qr/opt-mochitest-browser-chrome-1 (HPq2DeLoRmOdx4TMLcKblg)
      - test-windows11-64-2009-qr/opt-mochitest-browser-chrome-1 (CxhDutiXRxO4iHvGfXvSLA)
      - test-windows11-64-2009-qr/opt-mochitest-browser-chrome-spi-nw-1 (H8YMFOkrTe-BBA5OatDBaA)
      - test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-1 (fRUUrAHqQFiEEyKRCvt0IA)
      - test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-a11y-checks-1 (HTudU6z5SYy4bjdfQeUFPA)
      - test-linux1804-64-qr/opt-mochitest-browser-chrome-spi-nw-1 (U-P0-BO5QIODySalr-FOjA)
      - test-macosx1015-64-qr/opt-mochitest-browser-chrome-1 (RrDYuoh_TQKKExP1SfK7Iw)
      - test-macosx1015-64-qr/opt-mochitest-browser-chrome-spi-nw-1 (WJclUy5tSCSDgcUaWAp18g)

These failures could mean that the library update changed something and caused
tests to fail. You'll need to review them yourself and decide where to go from here.

In either event, I have done all I can and you will need to take it from here. If you
don't want to land my patch, you can replicate it locally for editing with
./mach vendor toolkit/components/pdfjs/moz.yaml

When reviewing, please note that this is external code, which needs a full and
careful inspection - not a rubberstamp.

Assignee: update-bot → cdenizet
Flags: needinfo?(cdenizet)
Attachment #9376278 - Attachment is obsolete: true
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Flags: needinfo?(cdenizet)
Resolution: --- → INVALID
Resolution: INVALID → WONTFIX
No longer blocks: 1669097, 1856218, 1869767, 1875357
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: