Closed Bug 187660 Opened 17 years ago Closed 16 years ago

Internet Keywords: search results returned instead of "connection refused" error

Categories

(SeaMonkey :: Location Bar, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 184433

People

(Reporter: jmd, Assigned: hewitt)

References

()

Details

Enter "localhost:8080" into the URL bar. Assuming your PC doesn't have that port
open, connection fails, and mozilla searches for "localhost" on the keyword server.

If the port is specified, it's obviously a address and not a keyword, so no
search should be executed. The user should see an error page saying the
connection was refused.

(I mentioned this in bug 181472 and was told to file it seperately)
This behavior is also more complicated, because I think Internet Keywords does
not fire for IP addresses which are connection refused.
Summary: Internet Keywords firing for localhost:8080 → Internet Keywords: search results returned instead of "connection refused" error
This is a dup of bug 184433.

*** This bug has been marked as a duplicate of 184433 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
V/dupe.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.