mozilla crashes on kde 3.0.5a (stable)

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: omgs, Assigned: asa)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3; Linux 2.4.17; X11; es, es_ES)
Build Identifier: 

I've upgraded from KDE 2.2.2 to 3.0.5a (this is said stable) in debian woody 
(I only use mozilla.org builds). All the other software seems to work OK, but 
when I execute Mozilla, I get the following: 
 
$ /usr/local/mozilla/mozilla 
(QFA)Talkback error: Can't initialize. 
 
Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with 
width 45061 and height 8500 
Gdk-ERROR **: BadAlloc (insufficient resources for operation) 
  serial 511 error_code 11 request_code 53 minor_code 0 
 
 
I should get the profile manager window, since I have several profiles, but 
keeping my actual ~/.mozilla directory, there's "about something" that freezes 
almost all the processes and, after about 10 seconds, exits. If I rename the 
directory, the error is inmediate, with no system-freeze. I need to have 
several versions of Mozilla in my hard disk (all in 
/usr/local/mozilla-<version>), and when I need to use one, I just create a 
symlink called /usr/local/mozilla to the proper directory. 

Reproducible: Always

Steps to Reproduce:
1. Have KDE 3.0.5a installed 
2. Execute Mozilla 
3. 
Actual Results:  
$ /usr/local/mozilla/mozilla 
(QFA)Talkback error: Can't initialize. 
 
Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with 
width 45061 and height 8500 
Gdk-ERROR **: BadAlloc (insufficient resources for operation) 
  serial 511 error_code 11 request_code 53 minor_code 0 
 

Expected Results:  
Just launch normally, with no errors.

Updated

16 years ago
Keywords: crash

Comment 1

16 years ago
could you grab a stacktrace?
% mozilla -g -d gdb
(gdb) b main
(gdb) run
(gdb) b exit
(gdb) cont
[make Mozilla crash]
(gdb) bt

and then attach the stack here
Keywords: stackwanted
(Reporter)

Comment 2

16 years ago
I've seen that numbers change depending on the mozilla version. This is for 
v1.3a from mozilla.org. I have added the "bt" because it might contain useful 
info about libs in my system (I hope not to be too much): 
 
(gdb) cont 
Continuing. 
(no debugging symbols found)...(no debugging symbols found)...(no debugging 
symbols found)... 
(no debugging symbols found)...(no debugging symbols found)...(no debugging 
symbols found)... 
(no debugging symbols found)...(no debugging symbols found)...(no debugging 
symbols found)... 
(no debugging symbols found)...(no debugging symbols found)...(no debugging 
symbols found)... 
(QFA)Talkback error: Can't initialize. 
(no debugging symbols found)...(no debugging symbols found)...(no debugging 
symbols found)... 
(no debugging symbols found)...(no debugging symbols found)...(no debugging 
symbols found)... 
(no debugging symbols found)...(no debugging symbols found)...(no debugging 
symbols found)...[New Thread 2049 (LWP 2969)] 
[New Thread 1026 (LWP 2970)] 
[New Thread 2051 (LWP 2971)] 
 
(no debugging symbols found)...(no debugging symbols found)...(no debugging 
symbols found)... 
(no debugging symbols found)...[New Thread 3076 (LWP 2974)] 
(no debugging symbols found)...(no debugging symbols found)... 
(no debugging symbols found)...(no debugging symbols found)...(no debugging 
symbols found)... 
(no debugging symbols found)...(no debugging symbols found)...(no debugging 
symbols found)... 
(no debugging symbols found)...(no debugging symbols found)...(no debugging 
symbols found)... 
(no debugging symbols found)...(no debugging symbols found)...(no debugging 
symbols found)...[New Thread 4101 (LWP 2982)] 
 
(no debugging symbols found)...(no debugging symbols found)...[New Thread 5126 
(LWP 2983)] 
[New Thread 6151 (LWP 2984)] 
 
Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with 
width 45061 and height 8500 
Gdk-ERROR **: BadDrawable (invalid Pixmap or Window parameter) 
  serial 508 error_code 9 request_code 55 minor_code 0 
 
Breakpoint 2, 0x40510dd5 in exit () from /lib/libc.so.6 
(gdb) bt 
#0  0x40510dd5 in exit () from /lib/libc.so.6 
#1  0x403433df in gdk_beep () from /usr/lib/libgdk-1.2.so.0 
#2  0x403dc9cd in _XError () from /usr/X11R6/lib/libX11.so.6 
#3  0x403db07b in _XReply () from /usr/X11R6/lib/libX11.so.6 
#4  0x403d7ea1 in XTranslateCoordinates () from /usr/X11R6/lib/libX11.so.6 
#5  0x403609a9 in gdk_window_get_origin () from /usr/lib/libgdk-1.2.so.0 
#6  0x40e1fbba in NSGetModule () from 
/mnt/hdc2/usr/local/mozilla-v1.3a/components/libwidget_gtk.so 
#7  0x402a21b5 in gtk_marshal_NONE__NONE () from /usr/lib/libgtk-1.2.so.0 
#8  0x402d1b6c in gtk_signal_remove_emission_hook () from 
/usr/lib/libgtk-1.2.so.0 
#9  0x402d0fd5 in gtk_signal_set_funcs () from /usr/lib/libgtk-1.2.so.0 
#10 0x402cf0b3 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0 
#11 0x40e3bfab in gtk_mozarea_get_toplevel_focus () from 
/usr/local/mozilla-v1.3a/libgtksuperwin.so 
#12 0x4034e174 in gdk_input_remove () from /usr/lib/libgdk-1.2.so.0 
#13 0x4034e29e in gdk_add_client_message_filter () from 
/usr/lib/libgdk-1.2.so.0 
#14 0x4034f20c in gdk_wm_protocols_filter () from /usr/lib/libgdk-1.2.so.0 
#15 0x4034f436 in gdk_wm_protocols_filter () from /usr/lib/libgdk-1.2.so.0 
#16 0x4037f4d8 in g_get_current_time () from /usr/lib/libglib-1.2.so.0 
#17 0x4037fae3 in g_get_current_time () from /usr/lib/libglib-1.2.so.0 
#18 0x4037fb95 in g_main_iteration () from /usr/lib/libglib-1.2.so.0 
#19 0x40e0caac in NSGetModule () from 
/mnt/hdc2/usr/local/mozilla-v1.3a/components/libwidget_gtk.so 
#20 0x40ddcdc7 in NSGetModule () from 
/mnt/hdc2/usr/local/mozilla-v1.3a/components/libnsappshell.so 
#21 0x40de729c in NSGetModule () from 
/mnt/hdc2/usr/local/mozilla-v1.3a/components/libnsappshell.so 
#22 0x40ddaeea in NSGetModule () from 
/mnt/hdc2/usr/local/mozilla-v1.3a/components/libnsappshell.so 
#23 0x406eff4f in NSGetModule () from 
/mnt/hdc2/usr/local/mozilla-v1.3a/components/libembedcomponents.so 
#24 0x406ee9ae in NSGetModule () from 
/mnt/hdc2/usr/local/mozilla-v1.3a/components/libembedcomponents.so 
#25 0x406edc34 in NSGetModule () from 
/mnt/hdc2/usr/local/mozilla-v1.3a/components/libembedcomponents.so 
#26 0x406ece35 in NSGetModule () from 
/mnt/hdc2/usr/local/mozilla-v1.3a/components/libembedcomponents.so 
#27 0x40edf61f in NSGetModule () from 
/mnt/hdc2/usr/local/mozilla-v1.3a/components/libprofile.so 
#28 0x40ee050f in NSGetModule () from 
/mnt/hdc2/usr/local/mozilla-v1.3a/components/libprofile.so 
#29 0x40edd9c9 in NSGetModule () from 
/mnt/hdc2/usr/local/mozilla-v1.3a/components/libprofile.so 
#30 0x40de27b0 in NSGetModule () from 
/mnt/hdc2/usr/local/mozilla-v1.3a/components/libnsappshell.so 
#31 0x08050522 in getCountry () 
#32 0x08051236 in getCountry () 
#33 0x08051c8f in main () 
#34 0x404fe14f in __libc_start_main () from /lib/libc.so.6 
(gdb) 

Comment 3

16 years ago
do you crash with latest nightly build and a fresh profile ?
http://ftp.mozilla.org/pub/mozilla/latest/nightly
(Reporter)

Comment 4

16 years ago
If it's absolutely necessary, I'll try and download a nightly build, but I 
need to launch the other versions, because I'm involved in localizacion 
projects for these versions. 
 
One more thing: trying and trying, what appears and quickly disappears has a 
title bar saying "Confirm migration". Hope it helps. 
(Reporter)

Comment 5

16 years ago
I have finally made it work. I could see that galeon was showing very bad boxes
on the screen, like the search box in google you all know, or any of the boxes
above this additional comments box, that there wasn't room even in several whole
screens for it. I decided to take a look to see what could I find for "widgets",
and a "dpkg -l *widget*" showed me "iwidgets3.1", so I did "apt-get install
iwidgets3.1", restarted kde and mozilla didn't crash (the same way). I've had to
reinstall v1.0.1 and adapted some file to be back to work.

Now it works for me, but:

1) There could be some issue in a kde upgrade involving mozilla, and this could
happen again to anybody else trying as I did, so maybe there should a more
strict analysis of why now it works (don't fully trust me about the iwidgets, I
might be wrong), in order to give a quick solution if happens again.
2) If it really is a somebody else's packaging bug, act consequently contacting
or do what think appropiate.

I don't change the status, because I don't know what should I do now, but
there's no problem in resolving the bug the way you want.

Comment 6

16 years ago
do you know what the iwidget package is?
(Reporter)

Comment 7

16 years ago
No, I don't know. I did it, apart from what I said, because in the error said
something about widgets, and I found that package uninstalled. If it has nothing
do, I don't know what I did to make it work, because restarting the X server was
my first option and didn't work.
Sorry for the annoyances.

Comment 8

16 years ago
no problem.  I'm thinking that installing the new KDE might have
a) conflicted with an old package Mozilla tried to use
   (fixed by upgrading the package to something kde3 likes)
b) upgraded an old package that Mozilla/gtk needed
   (fixed by installing a backward-compatibility package)

since KDE does qt and Mozilla uses gtk, one wouldn't really expect a problem.

I poked around and came up with this for iwidgets:
http://incrtcl.sourceforge.net/iwidgets/

I'm not sure why/how that would Mozilla.  Could you try uninstalling the package
and see if the problem returns?
(Reporter)

Comment 9

16 years ago
I've upgraded to kde 3.1 and the problem happened again. I tried to uninstall
the iwidgets and install again, but didn't help. Finally, loggin out, restarting
the X server from kdm and loggin in again solved the problem. I didn't try
directly to log in and log out. This 3.1 is a cvs version, so I'll wait a few
days for a new release and try whatever is decided.

If someone wants to try, this 3.1 was downloaded with the line in sources.list:
deb http://ktown.kde.org/~nolden/kde/woody/i386 ./

About the resolution of the bug, whatever is decided will be good.

Comment 10

16 years ago
marking WORKSFORME.  problem seems to have gone away and we don't really know
what was wrong.

please reopen if it shows up again and you have more info.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.