libjsd.so required when building with --disable-jsd

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
16 years ago
14 years ago

People

(Reporter: sta130, Assigned: netscape)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2.1) Gecko/20021130

cougar ;) ./configure --disable-{mailnews,tests,jsd,composer,debug,dtd-debug,bidi}

Build was succesful, with no errors

[...]
cougar ;) cd dist/bin
cougar ;) ./mozilla
./mozilla-bin: relocation error:
/morestuff/mozilla/dist/bin/components/libjsd.so: undefined symbol: NS_CurrentThread

cougar ;) ldd mozilla-bin 
        libgkgfx.so => libgkgfx.so (0x40013000)
        libjsj.so => libjsj.so (0x4004a000)
        libmozjs.so => libmozjs.so (0x4006b000)
        libxpcom.so => libxpcom.so (0x400ff000)
        libplds4.so => libplds4.so (0x40238000)
        libplc4.so => libplc4.so (0x4023c000)
        libnspr4.so => libnspr4.so (0x40242000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x4029e000)
        libdl.so.2 => /lib/libdl.so.2 (0x402b3000)
        libgtk-1.2.so.0 => /usr/lib/libgtk-1.2.so.0 (0x402b6000)
        libgdk-1.2.so.0 => /usr/lib/libgdk-1.2.so.0 (0x403e4000)
        libgmodule-1.2.so.0 => /usr/lib/libgmodule-1.2.so.0 (0x40419000)
        libglib-1.2.so.0 => /usr/lib/libglib-1.2.so.0 (0x4041d000)
        libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x40441000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x40449000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x40456000)
        libm.so.6 => /lib/libm.so.6 (0x4052b000)
        libstdc++-libc6.2-2.so.3 => /usr/lib/libstdc++-libc6.2-2.so.3 (0x4054c000)
        libc.so.6 => /lib/libc.so.6 (0x40590000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
It looks like you built with jsd, ran mozilla (or one of the test programs)
which created the component registry with a pointer to libjsd.so and then you
reconfigured & rebuilt.  Do you hit this same problem if you build from scratch
using those options or remove dist and rebuild?
WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 3

16 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.