can't retrieve local mail from my /var/spool/mail directory.

RESOLVED INCOMPLETE

Status

--
enhancement
RESOLVED INCOMPLETE
16 years ago
5 years ago

People

(Reporter: joelr, Unassigned)

Tracking

Trunk
Other
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1; MultiZilla v1.1.32 final) Gecko/20021212
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1; MultiZilla v1.1.32 final) Gecko/20021212

Pretty obvious -- I'm running fetchmail to pick up mail from several accounts
and put them in my local mailspool.  If there's a way to get mozilla mail to
read the mail spool, I haven't found it.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
-> invalid

see under movemail
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Product: MailNews → Core
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 2

6 years ago
movemail can stand a number of improvements, unfortunately, because its setup can confuse even an otherwise seasoned user:

1. To create it one needs to go into Edit->Settings->Account Actions->Setup Other Account. This "Other" part is confusing, because, of course, we are talking about a mail-account, yet, "Add Mail Account" means something else in this context. This may explain the difficult Matthias had.
2. The created account is set to look for mail deep under profile instead of under /var/mail (or /var/spool/mail), where it really is. Various online manuals, such as http://askubuntu.com/questions/192572/how-read-local-email-in-thunderbird advise users, how to change the location. However, such changing, for some reason, requires a full restart of Thunderbird.
3. After the account is set to /var/mail, the user sees the FULL list of files in there, which can be quite long on some systems. The should contain only the mailbox matching the content of the otherwise unused "username" setting of the account. An even nicer implementation would scan the entire directory and list the files readable to the current user.
4. Finally, not just a usability, but a real bug: the spool directory (rather than just the particular mbox) currently must be writable by the user. This is a subject of Bug 846853

Updated

6 years ago
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---

Comment 3

5 years ago
Mikhail, Thanks for having an interest in movemail. 

Comment 0 isn't much a description, nor is this bug's summary. If not for your comments this bug should be incomplete.  But, if this bug is not a duplicate of another open movmail bug [1], what do you think should be it's focus?  Or should it be a meta bug for a specific class of related movemail bugs?

[1] https://bugzilla.mozilla.org/buglist.cgi?f1=OP&o3=anywordssubstr&list_id=6808531&resolution=---&classification=Client%20Software&classification=Components&o2=anywordssubstr&f4=CP&query_format=advanced&j1=OR&f3=keywords&f2=short_desc&component=Movemail&product=MailNews%20Core&product=Thunderbird
Assignee: mscott → nobody
Component: Backend → Movemail
Flags: needinfo?(mi+mozilla)
QA Contact: esther
Summary: I'm unable to use Moziall mail to retrieve local mail from my /var/spool/mail directory. → can't retrieve local mail from my /var/spool/mail directory.

Comment 4

5 years ago
There is also bug 269372 which will try to sort out which file TB actually reads as the mail spool. This would cover point 2 of your list. Point 4 is covered in another bug as you pointed out. Point 1 is a matter of opinion, but I think there are other bugs for that. The account creation is to be rewamped in already filed bugs.

I did not understand point 3, can you explain more?

Updated

5 years ago
Whiteboard: [closeme 2013-07-14]

Comment 5

5 years ago
Resolved per whiteboard
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago5 years ago
Flags: needinfo?(mi+mozilla)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2013-07-14]
You need to log in before you can comment on or make changes to this bug.