moz_libdir, MRE_HOME variables incorrect after install. Install.log output inconsistent.

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: gretawatson, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

During install, got warning message:
    Warning:  MOZILLA_FIVE_HOME not set.
Post-install, values in /usr/local/mozilla/mozilla were wrong:
    moz_libdir=/usr/local/lib/mozilla-1.2.1
    MRE_HOME=/usr/local/lib/mre/mre-1.2.1
The install did not create those directories.  Everything was in
    /usr/local/mozilla.
A KDE user who docked /usr/local/lib/mozilla/mozilla to the panel using a
special button (non-KDE app), got a whole bunch of error messages in
.xsession-errors when invoking mozilla from the panel:
    Invalid entry (missing '=') at /usr/local/mozilla/mozilla:39
    Invalid entry (missing '=') at /usr/local/mozilla/mozilla:41
    Invalid entry (missing '=') at /usr/local/mozilla/mozilla:48
Same KDE user added a .htmlviewrc file containing:
    #!/bin/bash
    X11BROWSER=/usr/local/mozilla/mozilla
    export X11BROWSER
and could then run mozilla by invoking htmlview without getting those errors.

Root, using gnome, did not get the error messages when invoking mozilla from the
command line.

Reproducible: Always

Steps to Reproduce:
1.  Download mozilla-i686-pc-linux-gnu-1.2.1-sea.tar.gz.
2.  As root, extract using tar, into /root/mozilla.
3.  As root, execute the file /root/mozilla/mozilla-installer/mozilla-installer.
4.  Close the mozilla window that auto-starts.
5.  As non-root kde user, run mozilla first from the command line, and then
using htmlview.
Actual Results:  
See above details.

Expected Results:  
Either correct the values for moz_libdir and MRE_HOME, or create the directories
which correspond to those variables.  Also, suppress MOZILLA_FIVE_HOME message
by figuring out what it should be, maybe.

Here's part of what was in the install.log file:

    Mozilla Navigator
     -----------------

     ** initInstall: 0
     ** communicatorFolder: /usr/local/mozilla/
     ** File to delete: /usr/local/mozilla/components/libmozucth.so
     ** ERROR (-214): Deleting file: /usr/local/mozilla/components/libmozucth.so
     ** File to delete: /usr/local/mozilla/components/libpsmglue.so
                   ...
     ** addDirectory() returned: 0
     ** dirCreate() returned: 0
     [1/294]    Installing: /usr/local/mozilla/components/libucvmath.so
     [2/294]    Installing: /usr/local/mozilla/libprldap50.so
                   ...
     ** performInstall() returned: 0

     Install completed successfully  --  01/04/2003 16:17:37

Updated

16 years ago
URL: n/a
QA Contact: bugzilla → ktrina

Comment 1

16 years ago
I believe these vars are preliminary support for MRE- which is not incorporated
into Linux yet- should not cause problems running currently
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: ktrina → gbush

Comment 2

16 years ago
*** Bug 200274 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
Can I suggest placing a comment in the startup scripts MozillaFirebird,
firebird, and mozilla  to the effect that the moz_libdir and MRE_HOME variables
are or are not needed for specific OSs?

Comment 4

15 years ago
This (not updating moz_libdir and MRE_HOME) also occurs when you try to install
into a more local directory such as /home/username/mozilla.
Product: Browser → Seamonkey
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.2pre) Gecko/2008070401 SeaMonkey/2.0a1pre

Current trunk nightlies have no installer on Linux.
/usr/local/seamonkey/seamonkey exists and runs correctly AFAICT, even when started from non-root login. Its contents are fixed before distribution.

Resolving WORKSFORME. If you want to REOPEN, please mention in which recent version you see the bug, and include clear steps to reproduce.
Assignee: dveditz → nobody
QA Contact: agracebush → general
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.