[feature] Increase/Decrease font size need to be written

VERIFIED FIXED in M14

Status

SeaMonkey
Composer
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Charles Manske, Assigned: Joe Francis)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix in hand)

(Reporter)

Description

18 years ago
The HTML font size is always confusing to non HTML geeks, so use simple
"Increase Font Size" and "Decrease Font Size" buttons.
This should increase/decrease all text in a selection by 1 HTML unit,
adjusting existing "FONT SIZE=" values. Underlying code (nsHTMLEditor methods)
also need to be implemented.
(Reporter)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M12
(Reporter)

Comment 1

18 years ago
UI (the toolbar buttons) is implemented. Core methods
nsHTMLEditor::IncreaseFontSize and DecreaseFontSize need to be written.

Updated

18 years ago
Summary: Replace Font Size combobox with Increase and Decrease size buttons → [dogfood] Increase/Decrease font size need to be written

Comment 2

18 years ago
I see these new icons in the toolbar today but they don't seem to work.
This is a dogfood issue (need to be able to change the size of the text).
Change title to reflect latest comments by cmanske.

How do the new UI elements work if some of the selection is size 1 and some size
2?  Does it make them all size 2 or increment each part individually or make them
all size 3 or ???

Updated

18 years ago
Whiteboard: [PDT-]

Comment 3

18 years ago
Putting on PDT- radar.  Not needed for dogfood.

Updated

18 years ago
Blocks: 18951
(Reporter)

Updated

18 years ago
Target Milestone: M12 → M13
(Reporter)

Comment 4

18 years ago
Moving to M13

Comment 5

18 years ago
*** Bug 21755 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

18 years ago
Summary: [dogfood] Increase/Decrease font size need to be written → [feature] Increase/Decrease font size need to be written
Whiteboard: [PDT-]
Target Milestone: M13 → M14

Updated

18 years ago
Assignee: cmanske → jfrancis
Status: ASSIGNED → NEW
Target Milestone: M14 → M16

Comment 6

18 years ago
setting to m16 and reassigning to jfrancis
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

18 years ago
Target Milestone: M16 → M14
(Assignee)

Comment 7

18 years ago
moving to m14.  who needs sleep...

Comment 8

18 years ago
setting keyword
Keywords: beta1

Updated

18 years ago
Whiteboard: [PDT-]

Comment 9

18 years ago
Putting on PDT- radar for beta1.  Not critical to beta.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

18 years ago
fixed.  Sujay, it should be in todays build.  You dont need to wait a day.

Comment 11

18 years ago
it works, but we convert the indented text to blockquote style....

verified in 2/9 build.
Status: RESOLVED → VERIFIED

Updated

18 years ago
No longer blocks: 18951

Comment 12

18 years ago
I'm reopening this because it increase/decrease font size does not
work for partial text selection using 7/6 build.

1) enter some text
2) highlight half of the text
3) increase/decrease font size

nothing happens..

works if you select all of the text.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 13

18 years ago
fix in hand, very simple fix.
Status: REOPENED → ASSIGNED
Keywords: beta1 → nsbeta2
Whiteboard: [PDT-] → fix in hand
(Assignee)

Comment 14

18 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 15

18 years ago
verified in 7/25 build
Status: RESOLVED → VERIFIED

Comment 16

16 years ago
Build 2001091303
Win95 OSR-2 
Bug status is listed as fix but after highlighting text in
composer documents and using the keyboard shortcuts cntrl+= and cntrl+-
I noted the font size is still not being altered at all 
21755 also documents this occuring when attempting to resize with the
tool bar and that is also not fixed. 
Reproducible: Everytime
(Reporter)

Comment 17

16 years ago
Isn't the "new" problem simply a dup of bug 99406?

Comment 18

16 years ago
no, it's yet a different problem.  I think it's either that the shortcut keys 
don't work on Windows or that someone else has defined a conflicting shortcut key 
so ours isn't getting triggered.  Regardless, please do NOT open up bugs that 
were fixed and verified more than 6 months ago.  I believe there *is* a bug filed 
on the issue raised above (look for "ctrl-+").
Component: Editor: Core → Editor: Composer
(Reporter)

Comment 19

16 years ago
Using Ctrl + and Ctrl - work just fine to increase/decrease font size of both 
selected text or at the caret (Windows2000, build from 9/20/01.
Please be sure there are not <font size=...> tags in the text you are testing.

Comment 20

16 years ago
Regardless of current behavior, please take it to another bug; this bug is 
ancient.

Fixed/Verified Bugs older than 6 months should be left as such.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.