links inside a table that visibility changed to visible don't work it is done with onMouseOver() but do work if its done with onClick()

RESOLVED DUPLICATE of bug 132592

Status

()

Core
DOM: Events
--
major
RESOLVED DUPLICATE of bug 132592
15 years ago
15 years ago

People

(Reporter: Erik Günther, Assigned: saari (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030102
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030102

I'm working an a theme to phpwiki and was planing to use menus. To view the
menus  I use a javascript that change visibility to visible. That part works
fine with both onMouseOver() and onClick(). But the links in the menu don't work
at all when I view the menu with onMouseOver() but they work fine when I use
onClick(). I open the same menu with the same function in both cases.

I http://as2-2-6.ld.bonet.se/~erikg/noworking.html I have an exampel with
onMouseOver() and http://as2-2-6.ld.bonet.se/~erikg/working.html with onClick().
I have also notice the same error on www.nvidia.com. And galeon 1.2.7 also have
the same error. So I prety serten that I'm have programed right and there are a
 one more bug in Mozilla :/ 


Reproducible: Always

Steps to Reproduce:
1. Make a webpage with hidden menus that gets visual with onMouseOver() or look
at the link above.
2. The links in the menus don't work.



Actual Results:  
The menu just dissaper and nothing more

Expected Results:  
Try to load the link.

Comment 1

15 years ago
WFM on WinXP with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b)
Gecko/20030104. Menu appeared and then links loaded so I could move throu
working and non-working pages through it.
.
Assignee: rogerl → saari
Component: JavaScript Engine → DOM Events
QA Contact: pschwartau → vladimire
(Reporter)

Comment 3

15 years ago
Hmmm it looks like that this bug don't appere in windows a freand of mine have
tested in Windows Mozilla 1.2.1 and it works for him. 

Comment 4

15 years ago
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130.

After loading the URL and when moving mouse pointer onto "Menu >>>", box appears
including three links in table. I can choose a link and Mozilla loads
working.html. Also working.html seems to work fine.

Comment 5

15 years ago
WFM: XP Pro SP1, 1.3b build 20030104 both menus WFM at working.html and
noworking.html

Comment 6

15 years ago
the 'not working' case is bug 132592 (clicking fires mouseout, which closes the
menu out from under the pointer before the click event fires)

the 'working' case actually doesn't work at all (mouseout from the menu does not
close menu).  after debugging it a bit, it appears that the script confuses
Mozilla (or perhaps Mozilla confuses the script) and the tracking in menu[m]
gets messed up.

dupe of "onMouseOut triggered by mouse click prevents menu from working"

*** This bug has been marked as a duplicate of 132592 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.