Mozilla borwser is unable to display pages in "Gujarati" language ..

RESOLVED WORKSFORME

Status

()

Core
Internationalization
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: jignesh patel, Assigned: smontagu)

Tracking

({intl})

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc3) Gecko/20020523
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc3) Gecko/20020523

When I visit any of the above site, Mozilla is displaying all junk character, If
I use IE on same PC, then i can read both the websites. This websites are in
"Gujarati" language. I have also installed fonts on my local pc. It may be due
to UTF  support 

Thanks
Jignesh

Reproducible: Always

Steps to Reproduce:
1.visit www.sandesh.com using mozilla.
2.visit www.sandesh.com using ie.
 

Actual Results:  
Mozilla display junk character.
IE display correct character.

Expected Results:  
Display same character as IE.
I have no idea how this:
  <meta http-equiv="Content-Type" content="text/html; charset=x-user-defined">
which http://www.sandesh.com/ depends on, is supposed to work in the real world.
 At a minimum you'd need to set up Gujarati fonts in the User Defined section of
font prefs, but I don't know if that would even work.

->i18n
Assignee: font → smontagu
Component: Layout: Fonts and Text → Internationalization
QA Contact: ian → ylong
http://www.gujaratsamachar.com uses both an x-user-defined charset and a
downloadable font via @font-face.
Created attachment 110730 [details]
file that should demonstrate Gujarati text in UTF-8 encoding

This file should demonstrate the way that Mozilla should already support the
display of Gujarati text -- it uses a well known encoding, UTF-8, to encode the
correct Unicode codepoints of the characters.

Comment 5

15 years ago
Look here. http://www.w3.org/International/O-charset-ms.html

x-user-defined is a Nonstandard charsets with special meaning inside Internet
Explorer and MLANG, Uses windows-1252 decoder allowing any font. Designed to
support "webfonts" that replace Latin1 with user defined characters.

Comment 6

15 years ago
See also bug 186463 comment 5, where there is a problem with the Tamil language.
They don't seem to use Windows-1252 however, but TSCII. You'll have to add the
language yourself to the user-defined section of the font-preferences (just like
David said). Does that help in this case ?

The real solution is to change these webpages to use proper Unicode charset, not
to use their own charsets. Otherwise I don't know what to do with a user that
wants to read both, for instance, Gujarati and Tamil webpages. We can set up
only 1 font at a time.

Comment 7

15 years ago
Page http://www.sandesh.com/ has charset meta-tag "windows-1252" but frame has
"x-user-defined" charset.  In this case Mozilla was displayed as the higher
level (windows-1252).

Keywords: intl

Comment 8

15 years ago
For x-user-defined, the bytes from the document are passed through (actually
they get converted to and back from Unicode) to the font system and displayed
using the font configured for User-defined.  For details see bug 6588.

As noted in previous comments:  You should be able to view these pages by
configuring an appropriate font for user-defined, but it is limited to one font
mapping at a time.

Comment 9

14 years ago
i have downloaded all the Gujarati Fonts but i am still not able to view it in
mozila and it works on the internet explorer. So i use the internet explorer,
but if it works in mozilla it will be grate.
this are the links that i tried to view in mozilla but it does not work
URL LINKS: http://www.sandesh.com, http://www.bombaysamachar.com,
http://www.chitralekha.com/chitra_guj/homeg_free1.asp,
http://www.gujaratsamachar.com, http://www.jaihinddaily.com,
http://www.sambhaav.com, http://www.divyabhaskar.co.in,
http://www.saurashtrasamachar.net/home/index1.asp

Comment 10

14 years ago
i have downloaded all the Gujarati Fonts but i am still not able to view it in
mozila and it works on the internet explorer. So i use the internet explorer,
but if it works in mozilla it will be grate.
this are the links that i tried to view in mozilla but it does not work
URL LINKS: http://www.sandesh.com, http://www.bombaysamachar.com,
http://www.chitralekha.com/chitra_guj/homeg_free1.asp,
http://www.gujaratsamachar.com, http://www.jaihinddaily.com,
http://www.sambhaav.com, http://www.divyabhaskar.co.in,
http://www.saurashtrasamachar.net/home/index1.asp

Comment 11

14 years ago
and also if you would like to download any Gujarati fonts and numbers it is
listed in on the URL Link in the message
Thanks

Comment 12

14 years ago
 In Edit|Preference | Appearance | Font, did you check 'allow documents to use
other fonts'?

Comment 13

13 years ago
(In reply to comment #12)
>  In Edit|Preference | Appearance | Font, did you check 'allow documents to use
> other fonts'?
> 
> 

i didn't get what i suppose to do. i am suppose to change the character encoding?
because i tryed it and did not work and this is about year or so since we have
this discussion. so if you have info or new update please let me know. Thank you.

Comment 14

13 years ago
(In reply to comment #12)
>  In Edit|Preference | Appearance | Font, did you check 'allow documents to use
> other fonts'?
> 
> 

i didn't get what i suppose to do. i am suppose to change the character encoding?
because i tryed it and did not work and this is about year or so since we have
this discussion. so if you have info or new update please let me know. Thank you.

Comment 15

13 years ago
(In reply to comment #14)

> i didn't get what i suppose to do. 
If you use Mozilla suite, you could have just followed my instruction.  If you
use firefox, it's a bit different. Go to Tools | Options | General and press the
button named 'Fonts & Colors' and you'll get a dialog box. Near its bottom,
you'll find 'Always use my font'. If it's checked, make sure that it's NOT checked. 

Comment 16

13 years ago
(In reply to comment #15)
> (In reply to comment #14)
> 
> > i didn't get what i suppose to do. 
> If you use Mozilla suite, you could have just followed my instruction.  If you
> use firefox, it's a bit different. Go to Tools | Options | General and press the
> button named 'Fonts & Colors' and you'll get a dialog box. Near its bottom,
> you'll find 'Always use my font'. If it's checked, make sure that it's NOT
checked. 
I dont see that option in mozilla 1.5 beta but anyways if i want to see this
language i have to change it everysingal time? if i do then that is no good. i
can just use internet explorer.
(Assignee)

Comment 17

13 years ago
(In reply to comment #16)
> I dont see that option in mozilla 1.5 beta but anyways if i want to see this
> language i have to change it everysingal time? if i do then that is no good. i
> can just use internet explorer.

In Firefox 1.5 Beta it's different again. Go to Tools | Options and select
"Content". From there press the lower "Advanced" button, (the one in the "Fonts
and Colors" group). In the dialog that comes up, you should make sure that the
check box "Allow pages to choose their own fonts, instead of my selections
above" is checked. You only have to do this once.

Comment 18

12 years ago
I've found this issue with the current build of Firefox too. In the past, Firefox would accurately use the Apple supplied GujaratiMT unicode fonts to render glyphs from the Gujarati range.

With the current release, this is no longer the case. Also, for some reason, it is impossible to see Gujarati fonts in the Advanced > Content panel when trying to manually specify which fonts to use to render Gujarati pages.

Comment 19

10 years ago
Any updates on this issue? I think it can be closed as above mentioned sites are rendering Gujarati well (some sites are specific to IE, Please note that).

All Unicode Gujarati website seems works well for me!
marking wfm based on comment #19
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.