bookmarks manager crashes after making invalid entry in personal toolbar by means of drag-and-drop

RESOLVED DUPLICATE of bug 158428

Status

SeaMonkey
Bookmarks & History
--
critical
RESOLVED DUPLICATE of bug 158428
15 years ago
13 years ago

People

(Reporter: Colin Boos, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

While reorganising my bookmarks, I was moving bookmarks in the Personal Toolbar.
There I managed to make a duplicate (recursive) entry of the Personal Toolbar
Folder itself, which results in a crash of the app when opening the bookmarks
manager. I believe the cuase is the fact that the bookmarks manager may be
confronted with a recursion that sould not occur: it tries to open the personal
toolbar folder, which contains a personal toolbar folder, etc.


Reproducible: Always

Steps to Reproduce:
1. Left mouse button down on the empty (right side) part of toolbar
2. Drag mouse pointer left, to one of the toolbar items. Mouse cursor
'no-entry'-sign then changes to arrow + rectangular box.
3. Move on over toolbar item; after you pass it, an insertion line appears.
4. Now release mouse button. Entry named "Personal Toolb..." is inserted in the
personal toolbar.
5. Now select "Bookmarks/Manager Bookmarks..." from the menu.

Actual Results:  
After this Mozilla crashes immediately. 
After restarting Mozilla, Personal Toolbar is unaltered.

Expected Results:  
Drag and drop should in this case not lead to creating the Personal Toolbar
Folder. Furthermore, the bookmarks manager should check and handle these types
of inconsistencies in the bookmarks file.
(Reporter)

Comment 1

15 years ago
Created attachment 110733 [details]
dr. Watson output

Comment 2

15 years ago
can you post Talkback ID for this crash "mozilla/bin/components/talkback.exe" ?
Suspect bug 158428.
Severity: normal → critical
Keywords: crash, stackwanted

Comment 3

15 years ago
got e-mail from reporter: "didn't send any through the feedback agent before,
but just did:
incident id = TB15858059X
I agree with your suggestion that it resembles bug 158428.
The recursion in the bookmarks file in attachment 96973 [details] effectively does the
same as my drag-and-drop action, altough in my case the changed bookmarks were
not written to disk yet"
Whiteboard: TB15858059X
nsTreeRows::Last
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsTreeRows.cpp, line 110]
nsTreeRows::Find
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsTreeRows.cpp, line 182]
nsTreeRowTestNode::FilterInstantiations
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsTreeRowTestNode.cpp,
line 95]
TestNode::Propagate
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsRuleNetwork.cpp, line 1045]
RootNode::Propagate
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsRuleNetwork.cpp, line 759]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1635]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695]
nsXULTreeBuilder::OpenSubtreeOf
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1695] 
Keywords: stackwanted
Whiteboard: TB15858059X

*** This bug has been marked as a duplicate of 158428 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.