Cannot redirect single frame; source code shows "come back and fix this later" comment :)

RESOLVED DUPLICATE of bug 196052

Status

--
blocker
RESOLVED DUPLICATE of bug 196052
16 years ago
7 years ago

People

(Reporter: chrisw, Assigned: adamlock)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: ALL RELEASES OF MOZILLA

With the ActiveX component (and any other wrapper), an event is thrown when a 
web page is loaded within a frame.  If we want to override the page being 
loaded, we can simply issue a call to replace the page with another.  HOWEVER, 
this only works in IE because the current Mozilla implementation does not 
support targeting a frame.  In IE, the current browser frame is passed into 
the event, but the Mozilla ActiveX control can only load a page into the MAIN 
window.

I traced this down into the Mozilla source code and there is a comment there 
indicating that this was simply left out temporarily and that it would be 
added in later.  Is there an update on a date when this will be available?

Reproducible: Always

Steps to Reproduce:
1. Add Mozilla ActiveX wrapper component to, say, a Visual Basic form.
2. load up a web page with multiple frames
3. Try to stop and then redirect just one of the frames
Actual Results:  
The desired page loads in the main frame, wiping out the entire frameset.

Expected Results:  
The desired page should load in the appropriate frame
(Reporter)

Comment 1

16 years ago
Created attachment 117906 [details]
Test case showing blocking bug (Mozilla 1.0 - Mozilla 1.3+) of parent frame accidentally substitued for subframe in BeforeNavigate2 event
(Reporter)

Updated

16 years ago
Severity: major → blocker
(Assignee)

Comment 2

16 years ago
This sounds like a specific instance of an identified problem. I'm going to dupe
this against bug 196052 which was specially raised to cover all known issues
with intercepting link clicks.

*** This bug has been marked as a duplicate of 196052 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

16 years ago
Flags: blocking1.4b?

Updated

16 years ago
Flags: blocking1.4b?
Component: Embedding: ActiveX Wrapper → Embedding: ActiveX Wrapper
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.