CIBC online banking works with Mozilla 1.2.1 but not Chimera 0.6

RESOLVED WORKSFORME

Status

Camino Graveyard
Accessibility
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Michel Jeanrie, Assigned: Brian Ryner (not reading))

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021220 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021220 Chimera/0.6+

At the CIBC (Canadian Bank) website on their login page
(https://www.pcbanking.cibc.com/english/servlet/SignOn) which is accessable from
the main page, when you enter a correct Card Number and Password you are
immediatly booted back to the main page with no acknowledgement.

This 'bug' was addressed in the main Mozilla build bug reports but it was old
and about to be closed.  I bring it up here because I had no problems doing the
online banking with Mozilla 1.2.1 but every time I try with Chimera 0.6 I get
rejected leading me to believe it is perhaps the way Chimera presents itself to
web sites as opposed to  previously mentioned CIBC incompatability.

Reproducible: Always

Steps to Reproduce:
1. Enter Bank Card number and password in assigned boxes.
2. Press Sign in Button.
3.

Actual Results:  
Browser returns to cibc main page.  Works in Mozilla but not Chimera.

Expected Results:  
Logged into the personal banking area of the website.
Do you see the problem in Mozilla 1.0?  Chimera is based off the 1.0 source and
does not have most of the fixes made between 1.0 and 1.2....
(Reporter)

Comment 2

15 years ago
Indeed Boris, your assumption was correct.  I downloaded Mozilla 1.0.1, tried
the CIBC site, and received the identical results as when using Chimera 0.6.  So
Mozilla 1.2 works but not 1.0.1 or Chimera 0.6.
In that case, this will be fixed automatically once Chimera updates to tip...
(though if this is a huge problem they could try to find the fix responsible and
port it over to the 1.0 branch....)

Updated

15 years ago
Summary: CIBC online banking (www.cibc.com) works with Mozilla 1.21 but not Chimera 0.6. → CIBC online banking works with Mozilla 1.2.1 but not Chimera 0.6

Comment 4

15 years ago
So now that we're on the trunk is this fixed? Reporter, can you download a
nightly build, try to log in and report back?

Comment 5

15 years ago
Michel, can you confirm/deny that this is fixed in current Camino Nightly builds?
Reporter could  you please update the sttaus of this bug ?
Michel pourrais-tu s'il te plait tester avec une version récente de Camino, voir
même avec la version 0.7 de Camino ?
Et nous dire si les bug est toujours présent.

merci.

Comment 8

14 years ago
Since Camino is long-since moved on from moz-1.0, this bug is almost certainly
fixed. Resolving WFM. Reporter, if it's still a problem, please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.