Closed Bug 1878517 Opened 4 months ago Closed 3 months ago

conic-gradient with multiple stops renders incorrectly

Categories

(Core :: Graphics: Canvas2D, defect)

Firefox 122
defect

Tracking

()

RESOLVED DUPLICATE of bug 1851963
Tracking Status
firefox-esr115 --- unaffected
firefox122 --- wontfix
firefox123 --- fixed
firefox124 --- fixed

People

(Reporter: mcbain.asm, Unassigned)

References

(Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(2 files)

Attached file conic.html

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:122.0) Gecko/20100101 Firefox/122.0

Steps to reproduce:

  1. Create a Canvas
  2. Draw a conic gradient to the canvas with an #ff8c00 and an #ffed00 stop, in that order

Actual results:

Only one color draws, in olive drab. (All colors are washed out.)

Expected results:

There should be two colors: bright orange then yellow. The top half will be yellow, the bottom orange.

Edge (and presumably all Chromium derivatives) render this correctly.

Attached file conic2.html

When more colors stops are added, it's easier to see the color washout and it still skips the orange, in favor of a larger section of yellow.

Actually it also replaces the last two stops with gray, I just noticed. It will render the second stop if I swap it for a different color, but the last two will still remain gray.

This isn't particular to "hard stops," as if the second stop for each color is removed orange will appear (but not as much as it should, when compared with Edge), and the end stops will still be rendered gray.

The Bugbug bot thinks this bug should belong to the 'Core::Graphics: Canvas2D' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Graphics: Canvas2D
Product: Firefox → Core

:sergesanspaille, since you are the author of the regressor, bug 1834815, could you take a look? Also, could you set the severity field?

For more information, please visit BugBot documentation.

Flags: needinfo?(sguelton)

As an FYI, my observation of the washed out colors is covered by bug 1851963.

See Also: → 1851963

:lsalzman, can you comment to the bug?

Severity: -- → S3
Flags: needinfo?(lsalzman)

I second Art McBain, this should be covered by bug 1851963.

Flags: needinfo?(sguelton)
Status: NEW → RESOLVED
Closed: 3 months ago
Duplicate of bug: 1851963
Flags: needinfo?(lsalzman)
Resolution: --- → DUPLICATE
See Also: 1851963
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: