onmouseover, onmouseout events not sent

VERIFIED INVALID

Status

()

Core
DOM: Events
VERIFIED INVALID
15 years ago
15 years ago

People

(Reporter: Joe Castine, Assigned: saari (gone))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

The onmousout and onmouseover events are not even sent, which includes the
cursor change style to 'hand' and the fade of the td, which comes from the
script at http://www.windedhero.com/cgi-bin/fade.js. I am new at mozilla and bug
reporting, so i might not be explaining it right, but the td is supposed to fade
to 80 percent opacity, which doesnt seem to work in mozilla, yet works in mie.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.windedhero.com/board/index.shtml. It is all there.
Actual Results:  
The onmouseover and onmouseout events did not work, as they should.

Expected Results:  
The effect of fade.js makes it so when the cursor goes over a td, the cursor
changes to a hand and the td opacity is reduced from 100 percent to 80 percent.

i am running the modern theme, but it has the same error on both.
Browser, not Bugzilla
Assignee: justdave → saari
Component: Bugzilla-General → DOM Events
Product: Bugzilla → Browser
QA Contact: matty → vladimire
Version: unspecified → Trunk
'hand' is an IE-proprietary value of the 'cursor' property.  The standard value
you want (supported by every single modern browser except IE on Windows
(Mozilla, Opera, Konqueror, IE on Mac) is 'pointer'.  See
http://www.w3.org/TR/CSS21/ui.html#propdef-cursor

As for the 'fade' function, it starts with:

if (!document.all)
  return

document.all is an IE=proprietary extension to the DOM, and tests false in Mozilla.

Further, all the filter syntax in that function is not supported by any browser
other than IE/Windows.  The standard method of doing opacity in CSS3 is through
the inline style of the object....  Mozilla does not yet implement it fully
correctly, so it is available as object.style.MozOpacity; the value is a
floating point value between 0 (for transparent) and 1 (for fully opaque).

Marking invalid, since all the things that don't work don't work because they
are written to only work in IE/Windows.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 3

15 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.