No specification document for Mozilla found on mozilla.org

RESOLVED WONTFIX

Status

www.mozilla.org
General
RESOLVED WONTFIX
16 years ago
6 years ago

People

(Reporter: Marc-Etienne VARGENAU, Assigned: Hixie (not reading bugmail))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; fr-FR; rv:1.0.0) Gecko/20020611
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; fr-FR; rv:1.0.0) Gecko/20020611

I cannot find on mozilla.org a page giving the exact specification of what is
and is not implemented in Mozilla with respect to standards such as
HTML or CSS.

I would like something like
http://www.opera.com/docs/specs/
that is available for Opera.

That would prevent submitting bugs for things not implemented.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

16 years ago
WFM :)
http://mozilla.org/start/1.0/guide/product.html#standards
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

16 years ago
I am sorry, but I have to reopen this bug.
Perhaps I was not clear enough in my initial request.

I know the page you refered me to.
It says that Mozilla implements HTML 4 and CCS 2.

This is *NOT* 100 % true, and what I need to know is EXACTLY 
what is not implemented.

For instance, CSS2 counters do not work since the :before and
:after pseudo-elements are not implemented.

The page
http://www.opera.com/docs/specs/
for Opera gives this kind of information.

This would be very useful:
1) it would prevent submitting bugs about non-implemented things
2) it would help deciding in switching from one Mozilla version 
to the next one.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
-> Hixie
Assignee: endico → ian
Status: REOPENED → NEW

Comment 4

15 years ago
search Bugzilla for browser bugs with html4, css1, css2, css3, dom0, dom1, dom2,
or dom3 keyword then. I don't think anyone has time chasing down every
HTML/CSS/DOM bug

suggest wontfix
(Assignee)

Comment 5

15 years ago
The problem is that we change what we implement on a literally daily basis, so
it would be nearly impossible to keep such documentation up to date.

However, there have been efforts in this direction before. For example:

   http://www.mozilla.org/docs/web-developer/bugspecs/REC-CSS1.html

For more of these see: http://www.mozilla.org/catalog/web-developer/

WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → WONTFIX
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.