Closed Bug 187969 Opened 17 years ago Closed 16 years ago

zone.com/zone.msn.com - Passport login fails

Categories

(SeaMonkey :: General, defect)

x86
Windows 98
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: mseitz, Assigned: asa)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030106
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030106

On the zone.com home page is an icon to log in using Microsoft passport. 
Clicking this button brings up a Passport login page.  However, after enetering
the login information, a blank screen is displayed.

Reproducible: Always

Steps to Reproduce:
1.  Go to www.zone.com
2.  A warning will be displayed that your browser is not fully supported.  Click
the "click here" link at the end of the page to continue despite the warning.
3.  Click the "Sign in" icon in the upper right corner
4.  Enter your login information and press the continue button.

Actual Results:  
A blank screen is displayed.

Expected Results:  
A page requesting my date of birth should be displayed.

This bug appears similar to bug 187352.
Problem also occurs with builds 1.3.a, 1.2.1, 1.0.1, and 1.0.
wfm 2002121222 / linux. On the other hand http://www.zone.com reports that only
IE / netscape 6.2.2 are supported. So there is at least one Tech-Evangelism bug
here. Reporter, I suggest you move this bug to the Tech-Evangelism component for
the moment at least.
I performed the same steps using Internet Explorer, this time filling in the
form for reporting my birthdate.  Once that was done, I was able to login using
Mozilla.  So the problem appears only on Passport accounts that do not have the
user's birthday set.  Once that is set, the problem goes away.

I partially agree with Additional Comment #2.  The warning page about browser
compatability is an evangelism issue.  But that issue is different from this bug
report and should be a seperate item.  Until we know whether the Passport login
problem is caused by bad code on the web site, I don't think this bug should be
assigned to evangelism.
dup 187236
Blocks: MS
Depends on: 187236
I am not sure Mozilla bug 187969 should be considered a duplicate of bug 187236
(see http://bugzilla.mozilla.org/show_bug.cgi?id=187969#c4).  Bug 187969
concerns logging in and results in a blank screen.  Bug 187236 concerns logging
out and apparently returns to the original logout screen.  There are some
similarities, but I'm not sure they are the same bug.
WFM in Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030716.

Also, mseitz@yahoo.com, build 20030106 is old and was probably fixed already.
Please download a nightly build at ftp://ftp.mozilla.org/pub/mozilla/nightly and
see if this problem occurs on your end.

Thanks, 

Des. Ramzan
I had this problem in Mozilla 1.5
This has been fixed since Mozilla 1.6a
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.