Cookie confirm dialog box is cut off on right side (displayed incompletely)

VERIFIED WORKSFORME

Status

()

Core
Networking: Cookies
VERIFIED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Marc Rust, Assigned: Michiel van Leeuwen (email: mvl+moz@))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(8 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030104
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/2003010408

When going to
http://bugzilla.mozilla.org/enter_bug.cgi?product=Browser&format=guided ,
prompted to enter login and password. Having Mozilla setr to have user confirm
cookie, dialog box displaying cookie info is displayed incompletely. Also
happens at http://www.sneakemail.com , after attempting login. Attachment provided.

Reproducible: Always

Steps to Reproduce:
1. Set browser to prompt user for cookie acceptance
2. Go to URL http://bugzilla.mozilla.org/enter_bug.cgi?product=Browser&format=guided
3. sign in with username
4. wait for cookie accept dialog
Actual Results:  
Accept cookie dialog is cut off on right-hand side

Expected Results:  
Displayed full dialog box

Using Modern Theme
Standard tabs (NOT tabbrowser extension)
Dialup ISP
No other PC problems
(Reporter)

Comment 1

16 years ago
Created attachment 110857 [details]
Screenshot of dialog error

Comment 2

16 years ago
WFM, win2k, trunk build id 2003010808
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 3

16 years ago
Created attachment 112853 [details]
I have always this problem

This bug still alive with the current nightly build!

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030127
(Assignee)

Comment 4

16 years ago
Does clicking twice on the "show details" button help? That should resize the
window.

Comment 5

16 years ago
Thomas, do you see this problem in other dialogs like Form manager, Password
manager? I suspect this might be related to your system font.
(Reporter)

Comment 6

16 years ago
I originally reported the bug, and only problem I had was with the cookie 
accept dialog. Recall NO problems with Password Manager or other forms.

Comment 7

16 years ago
Created attachment 112958 [details]
Screenshots of 3 different cookie dialogs

Tried with Mozilla and Phoenix builds 2003-01-27.
Only Mozilla had this problem. Phoenix seems to resize the dialogs just fine.
Using Pinball theme on both browsers.
Clicking the "Show details" button resizes the window correctly.

Comment 8

16 years ago
> ------- Additional Comment #5 From suresh@netscape.com  2003-01-28 11:48 -------
>
> Thomas, do you see this problem in other dialogs like Form manager, Password
> manager? I suspect this might be related to your system font.

No, I not see this problem in other dialogs... Only with the cookies prompt!

Comment 9

16 years ago
Should not have been resolved WFM on the basis of just comment 2.  Only the
reporter of a bug should mark it as such, unless they are not responding to
email and nobody else can reproduce.  Obviously, there are enough people
reporting it that it's legitimate.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 10

16 years ago
mvl: I'm not sure what's causing this, but here are a few possibilities...

Comparing cookieAcceptDialog.xul to other random .xul dialogs, I notice the
following differences:

http://lxr.mozilla.org/seamonkey/source/extensions/cookie/resources/content/cookieAcceptDialog.xul#43
currently> <dialog id="cookieAcceptDialog"
add?     > style="width: 30em;"
not sure if this matters, but should we have this anyway? it might force a line
wrap and fix your "long line" problem...?

http://lxr.mozilla.org/seamonkey/source/extensions/cookie/resources/content/cookieAcceptDialog.xul#56
currently>  <hbox>
replace? >  <hbox flex="1">
general comment: not sure exactly which hbox/vbox needs it... suspect the first
hbox and vbox, #56 (#57?) and #61 respectively.

http://lxr.mozilla.org/seamonkey/source/extensions/cookie/resources/content/cookieAcceptDialog.js#150
currently>  sizeToContent();
We could put a call to sizeToContent() in the onload() function, but that
doesn't sound good. I'd be more inclined to play with the flex and stuff above,
to try to get it to flow correctly first time :)

1.3b looks like it still has a few days to go, so might be worth sorting this
out soon...

btw, unrelated nit, there's a spelling error on:
http://lxr.mozilla.org/seamonkey/source/extensions/cookie/resources/content/cookieAcceptDialog.xul#69
and
http://lxr.mozilla.org/seamonkey/source/extensions/cookie/resources/content/cookieAcceptDialog.js#153
onChangePersitence() -> onChangePersistence().
(Assignee)

Comment 11

16 years ago
> currently> <dialog id="cookieAcceptDialog"
> add?     > style="width: 30em;"
> not sure if this matters, but should we have this anyway? it might force a line
> wrap and fix your "long line" problem...?
Sizes should not be hard-coded into xul files. Also see bug 183700

> We could put a call to sizeToContent() in the onload() function, but that
> doesn't sound good. I'd be more inclined to play with the flex and stuff above,
> to try to get it to flow correctly first time :)
Maybe it will help. We are adding text in the onload function too.
(Assignee)

Comment 12

16 years ago
Created attachment 112987 [details] [diff] [review]
Add sizeToContent to onload

Maybe this will work. Can anybody who can reproduce this bug try this patch? I
can't reproduce it.

Comment 13

16 years ago
->CONFIRMED (!)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 14

16 years ago
Hmm. Tried with build 2003-01-28 on WinXP and the cookie window was properly
sized every time. With 2003-01-27 on W2K the window was cut off (see my comment #7).
(Assignee)

Comment 15

16 years ago
I take this for now. But anyone who can reproduce is free to take it from me.
Status: NEW → ASSIGNED
(Assignee)

Comment 16

16 years ago
Retry
Assignee: morse → mvl
Status: ASSIGNED → NEW

Comment 17

16 years ago
Reporter (or anyone else): Are you still seeing this problem with recent builds,
or was it actually fixed by something post 1/27 as per comment 14?

Comment 18

16 years ago
Still broken with Mozilla build 2003-01-30 on Windows 2000.
Maybe it has something to do with the OS, since I don't see this bug on WinXP.
Tried both XP styles and classic style..

Comment 19

16 years ago
still works for me on windows 2000, 2003-1-31 build.

can you guys try to create a new profile, and see if you can see the same dialog
problem using new user profile?
(Reporter)

Comment 20

16 years ago
Right after it happened, I did create a new profile, and it didn't help
a thing.

Comment 21

16 years ago
I cannot duplicate this bug in new profile.

Comment 22

16 years ago
I have been getting the same problem even with the latest version:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210

Comment 23

16 years ago
Created attachment 114256 [details]
Confirm box via Gecko/20030210 on XP (davebate@rogers.com)

Comment 24

16 years ago
I don't see this bug after creating a new profile. With my old profile the bug
always occurs. Mozilla 2003021208, Windows 2000.

Comment 25

16 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210
Windows XP, SP1

See this in 1.3b, did not ever see it before (up to 1.3a). See attachments.

Regarding the question in comment 4, yes, clicking the Show/Hide button (just
once) will resize it properly. However, initially this bug hides the No button
no matter the width of the affected buggy confirm box.

Someone should mark OS:XP, as XP is the latest version of Windows this bug
affects. Will try w/ new profile to see if that will "fix" things up...

Comment 26

16 years ago
Created attachment 114692 [details]
screenshot of cookie confirm box cutting off content

Comment 27

16 years ago
Created attachment 114693 [details]
screenshot of cookie confirm box

Notice the width of this confirm box is wider than the one in Attachment
#11469 [details] [diff], but it's cutting off part of Yes button and all of No button at exactly
the same area.

Comment 28

16 years ago
In comment 27, it should refer to attachment 114692 [details]. :)

Comment 29

16 years ago
*** Bug 193754 has been marked as a duplicate of this bug. ***

Comment 30

16 years ago
Mozilla 1.3b, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b)
Gecko/20030210, Windows XP

I upgraded this box from Windows 2000 to XP after throwing a fresh 1.3b on 2000.
This bug showed in 2000 as well as XP (different machine from the one reported
in comment 25). 
(Reporter)

Comment 31

15 years ago
Will this bug be fixed before 1.3 final, or is it considered too sporadic? I'm
using 1.2.1 now, and don't want to DL 1.3 final if this bug will still be present.
(Assignee)

Comment 32

15 years ago
It won't be fixed until a dev can reproduce the bug, or someone who can
reproduce it tries the patch I posted before.

Comment 33

15 years ago
Created attachment 115767 [details]
download progress box

The same thing is happening w/ the download progress box...

Comment 34

15 years ago
The problem has not appeared any more since several release. The cookies dialog
box is new! (->FIXED ?)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030227
(Reporter)

Comment 35

15 years ago
So the <a href="http://bugzilla.mozilla.org/show_bug.cgi?id=187975#c33">bug
reported yesterday</a> is unrelated?

Someone that has still has the cookie dialog problem (anyone?) should try the <a
href="http://bugzilla.mozilla.org/attachment.cgi?id=112987&action=view">patch</a>
mentioned earlier.

Maybe it IS fixed...

Comment 36

15 years ago
Haven't tried it under Linux yet, but this just started happening to me also
when I upgraded to 1.3 from 1.2.1 under Win2000.  Doesn't happen with any other
dialogs, just the cookie accept one.  When I start the browser, the very first
cookie dialog is ok, and then all of the following ones are cut off on the left.
 Toggling details does resize it correctly in every case.

Comment 37

15 years ago
I'm seeing this with the cookie dialog in 1.3 under Linux/x86. It was
fine in 1.3b, but started playing up with the 1.3 release. Note that
it's intermittent. Most of the time it works fine, but occasionally
the dialog box gets truncated.
(Assignee)

Comment 38

15 years ago
This will not be fixed until a developer can reproduce this. I surely can't. So
if you know how to apply patches, and see this bug, please try the suggested
patch. (It might not apply cleanly anymore, but the idea is that you add
SizeToContent() at the end of the onLoad function)
So we know it is broken for some people. Don't add comments that it is broken
for you too. We know it. Thanks.

Comment 39

15 years ago
as a followup note to mvl's comment, please note that it's not necessary to have
a build environment to test this patch - anyone who doesn't mind fiddling with
.jar files can test this.

Comment 40

15 years ago
Upgraded from 1.2.1 to 1.3 final last night (PC, Win98SE) and am experienceing
the same problem.
(Assignee)

Comment 41

15 years ago
*** Bug 199431 has been marked as a duplicate of this bug. ***

Comment 42

15 years ago
Mozilla 1.4a, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a)
Gecko/20030401, Windows XP build 2600.xpsp1.020828-1920

just tried out 1.4a & this annoying problem *finally* WFM. :D

Comment 43

15 years ago
Mozilla 1.4a
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401

Bug seems to be fixed with this release. I see another window than before, this
window is not cut-off. 

Comment 44

15 years ago
Is anyone still experiencing this? If not, can we close this? :)
resolving WORKSFORME since I haven't seen any comments from the last year
confirming this behaviour.  If someone can still replicate this, please reopen.
Status: NEW → RESOLVED
Last Resolved: 16 years ago14 years ago
QA Contact: tever → cookieqa
Resolution: --- → WORKSFORME

Comment 46

14 years ago
V:WFM, allplats
I've been spending more "quality time" w/ cookies on all plats, and I haven't
seen this.
Maybe some underlying stuff was flakey and finally fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.