Bug 188003 (MyFirstBug)

regression area tests fails (tests incorrect)

RESOLVED FIXED

Status

()

Core
DOM: Core & HTML
--
major
RESOLVED FIXED
16 years ago
15 years ago

People

(Reporter: Yves Lambert, Assigned: Prashant Desale)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2) Gecko/20030104
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2; MultiZilla v1.1.33 (b)) Gecko/20030104

In the page http://www.ifrance.com/chemsoudesign/ the ads javascript of
ifrance.com causes the page not to be dosplayed at all

Reproducible: Always

Steps to Reproduce:
1. go to http://mozilla.org/quality/browser/standards/javascript/tcmatrix/index.html
2. perform area tests
3. go to http://www.ifrance.com/chemsoudesign/index.htm

Actual Results:  
area001.html and area008.html fails
http://www.ifrance.com/chemsoudesign/ shows a blank page


Expected Results:  
2. pass successfully the test
3. display a frameset with
http://www.ifrance.com/heberg/pub.htm?Time=1041906204&Nom=chemsoudesign&FRAME=1
at the top
and something mostly like http://le.iota.free.fr/CheMsoU/index.html
(Reporter)

Updated

16 years ago
Depends on: 12543
(Reporter)

Comment 1

16 years ago
added 2 dependances
Depends on: 12559
Please test a recent build, not the ancient 1.0.2.... Trying the urls, I see the
following:

http://mozilla.org/quality/ngdriver/suites/javascript/are001.html -- the test is
buggy; Mozilla's behavior is correct.

http://mozilla.org/quality/ngdriver/suites/javascript/are008.html -- same thing
(and for the same reasons -- the search and hash portions are in the wrong order
in the source).

http://www.ifrance.com/chemsoudesign/index.htm -- shows a 404 and then redirects
to http://www.ifrance.com/heberg/

Over to DOM0
OS: Windows XP → All
Hardware: PC → All
Summary: regression area tests fails → regression area tests fails (test incorrect)
.
Assignee: rogerl → jst
Component: JavaScript Engine → DOM Level 0
QA Contact: pschwartau → desale

Comment 4

16 years ago
Reassigning to Prashant. Compare bug 142649, 
"Invalid testcases in JavaScript testcases"
Assignee: jst → desale

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

16 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b; MultiZilla v1.1.32
final) Gecko/20030106
my version was overrided :D
¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤
Correction to test:
Steps to Reproduce:
1. go to http://www.ifrance.com/chemsoudesign/index.html
***** changed infex.htm to index.html *******
Actual Results:  
area001.html and area008.html fails
http://www.ifrance.com/chemsoudesign/ shows a blank page


Expected Results:  

1. display a frameset with
http://www.ifrance.com/heberg/pub.htm?
at the top
and something mostly like http://le.iota.free.fr/CheMsoU/index.html
¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤¤

maybe assigned to w3c evangelism too (see ifrance.com scripts :\) tho displays
correctly in netscape 6+ and 4.78

Summary: regression area tests fails (test incorrect) → regression area tests fails (test corrected)
comment 5 showing bug 187790 (and what's with all the crap in that comment?)
(Reporter)

Comment 7

16 years ago
duplicate bug 187790

*** This bug has been marked as a duplicate of 187790 ***
Alias: MyFirstBug
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
reopening, since I see no indication that the DOM tests have been corrected.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: regression area tests fails (test corrected) → regression area tests fails (tests incorrect)
Does this bug actually depends on bug 12559, or on bug 146788 (are008.html)
"only" ? (see comment 2)

Comment 10

15 years ago
are008 and are001 are passed by my firebird0.6.1 on win2K. Marking FIXED. Please
reopen if the tests still fail for you.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.