Browser frequently crashes when "My Panels" is resized

VERIFIED DUPLICATE of bug 18876

Status

defect
P3
critical
VERIFIED DUPLICATE of bug 18876
20 years ago
15 years ago

People

(Reporter: oogybear, Assigned: slamm)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Resizing empty "My Panels" window sometimes crashes browser.  Doesn't happen at
www.mozilla.org if it's the very first thing I do; however, it *will* crash at
mozilla if I delete the URL (or even click in the URL window.)  It also happens
at www.altavista.com (i.e. complex HTML w/tables), www.attrition.org (relatively
bare-bones html) and some text-only pages I tried.
Severity: normal → critical
clarification: this is on Build 1999111308.
Oogy, when you say empty My Panels, does that mean you deleted all of your
panels using the customize dialogue. Is this necessary to cause the crash?

Please list the exact steps needed to reproduce this crash, as noted in
http://www.mozilla.org/quality/bug-writing-guidelines.html

Thanks.
OS: Windows 98 → Windows NT
Oops--I apologize for my imprecision.  Try this:

                   Steps to Reproduce:
                   1) Click in URL Text Box
                   2) Click and drag vertical bar of "My Panels" window

Actual Results: Mozilla crashes.
Expected Results: The window resizes normally.
Build Date & Platform Bug Found: 1999111408

As far as I can tell, the contents of the My Panels window have no effect.
One caveat, though: If you change the contents of the window, save those
changes, then try to resize the window, Mozilla will crash.  (I describe this
problem in more detail in a separate bug.)  HOWEVER, before you decide I'm
crazy, if you then reload Mozilla, it will load with that saved configuration,
and you will be able to resize the window normally (until you click in the URL
text box or change the contents of the My Panels window).  I tried multiple
configurations with no panels, all panels, and some panels (specifically sports,
white/yellow pages, travel, search, member directory, netcenter) and the results
were identical.  I therefore conclude that the contents of the window do not
make any difference.

Note also that if you simply click on a link and let it take you to another
page, you will still be able to resize the window.

Please let me know if I'm still not being clear....
OS: Windows NT → Windows 98
damn.  OS got switched to WINNT somehow.  It should be Win98.  Sorry for the
spam.
there was a bug in builds from last week where comboboxes (drop-down select
widgets) were selecting the wrong items, it has been fixed in recent builds.

Oogy, can you try this on today's build? I think the problem you are referring
to has been fixed.
Yep, this is fixed too.  And here I thought yesterday's build was recent enough.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
marking as a dup of 18876

*** This bug has been marked as a duplicate of 18876 ***
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.