If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Tab, Shift+Tab and arrow keys not working in Account Settings (Mac only)

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Account Configuration
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Ninoschka Baca, Unassigned)

Tracking

({access, regression})

Trunk
PowerPC
Mac OS X
access, regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Trunk build 2002-01-07-01: Mac X

Overview: Keyboard navigation in the Account Settings window has regressed
severely. Tab, Shift+Tab and arrow keys only highlight text boxes. Here are some
examples:

1. Account Setings panel (first panel)
a. Tab through all the elements and the Choose button is never highlighted
b. Try and tab to the Compose Messages in HTML format check box and it is never
highlighted

2. Server Settings
a. Try and tab to all elements and it skips the checkboxes, again it only
highlights the text boxes.

3. Copies and Folders
a. Try and tab and focus doesn't go anywhere since this panel consists of drop
down boxes and checkboxes and very few text boxes.

4. The rest of the panels exhibit the same behavior

5. Try and tab to the "Add Account", "Set As Default" and "Remove Account"
button but it fails to highlight any of these buttons.

Actual Results: Tab, Shift+Tab and arrow keys do not work when trying to
navigate through the Account Settings dialogs/panels. It only stops on text boxes.

Expected Results: Tab, Shift+Tab and arrow keys should work as expected,
highlighting all the elements of a dialog.

Additional Information:
Navigating through the dialogs via the keyboard was working in Netscape 7.01 so
this is a definite regression.
(Reporter)

Comment 1

15 years ago
Marking nsbeta1 because this makes managing accounts on Mac X via the keyboard
very poor. This has regressed since Netscape 7.01.

Additional Information:
trunk build 2003-01-07: WinMe, works simlar to 7.01.
trunk build 2002-12-20: Linux RH 8.0, works similar to 7.01.
Assignee: racham → sspitzer
Keywords: access, nsbeta1, regression

Comment 2

15 years ago
Mail triage team: nsbeta1-
Keywords: nsbeta1-

Updated

15 years ago
Keywords: nsbeta1
ninoschka, i think this should be working in current builds (branch and trunk)
on OS X. is this still a problem?

see also bug 188077 comment 4.
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail

Comment 4

12 years ago
No keyboard access to buttons and boxes in Thunderbird, only to text elements.
QA Contact: nbaca

Comment 5

9 years ago
Using tab/arrow, I can navigate through all ui elements in account settings with a recent seamonkey trunk build (mac os 10.5.6). --> wfm.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.