Closed Bug 1880925 Opened 2 months ago Closed 2 months ago

Pin the Android SDK platform-tools version to r34.0.5

Categories

(Release Engineering :: General, task)

Tracking

(firefox125 fixed)

RESOLVED FIXED
Tracking Status
firefox125 --- fixed

People

(Reporter: RyanVM, Assigned: RyanVM)

References

Details

Attachments

(1 file)

As was outlined in great detail in bug 1822171 comment 12 and later, the recently-released Android SDK platform-tools r35.0.0 is causing a lot of problems with adb connectivity in our test suite. Unfortunately, pinning the version is less than trivial as it has the same issue that we encountered with the emulator in bug 1869407 where only the latest release is available to sdkmanager. Therefore, let's extend the same hack used for that bug to platform-tools. I've confirmed on Try that it unblocks bug 1822171 from landing again.

We should also file a follow-up bug for getting to the root cause of the adb issues with the r35.0.0 platform-tools and removing this hack (bonus points if we can tackle the emulator too). This current method of manually undoing half of what sdkmanager is doing is unsustainable. But as things stand right now, this is a time bomb laying in wait for anyone who has the misfortune of triggering an Android toolchain rebuild at the moment and this seems like the most prudent option.

Pushed by rvandermeulen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6e5328b3e9ce
Pin platform-tools to r34.0.5. r=releng-reviewers,jcristau
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: