Preferences window does not refresh when you minimize then restore

VERIFIED WORKSFORME

Status

()

Core
XUL
P3
normal
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: oogybear, Assigned: Dan M)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Overview Description:

                 Steps to Reproduce:
                 1) Edit->Preferences
                 2) Minimize that window
                 3) Restore that window

Actual Results: The window reappears but does not refresh--part of it is gray
and part of it shows whatever's 'behind' it on the desktop.

Expected Results: It should refresh properly.

Build Date & Platform Bug Found: Win98 1999111308

Additional Builds and Platforms Tested On:

Additional Information:

Comment 1

19 years ago
Confirmed for WinNT using 1999-11-12-18-M11 nightly binary.

Additional Information:
1. Upon restoring, the non-grey area of the dialog show whatever had
been in that part of the screen just before restoring, and also a tall, narrow
(~60px) rectangle with a medium-heavy black border (on the left).
2. After that, if the focus is given to any app but Mozilla and then back
again, the list of panels in the pref UI appears in that narrow rectangle
(clipped on the right) and it appears that the rest of the dialog for each
pane is (trying to be) fitted into the rest of the area that had "shown
through." The rest of the pane, to the right, remains grey throughout.

Updated

19 years ago
Assignee: davidm → danm
Component: HTML Dialogs → XP Toolkit/Widgets

Comment 2

19 years ago
XP toolkit. Danm

Updated

19 years ago
Target Milestone: M14

Comment 3

19 years ago
p3 for m14
QA Contact: cpratt → sairuh
spam: in my testing realm, so reassigning qa contact to me, en masse.
(Assignee)

Comment 5

19 years ago
Prefs minimize and restore fine for me today (I even tried making the window 
modal, as it probably was when the bug was filed). Can't reproduce. Note I was 
testing on NT, not '98. But it sounds like a transient content problem to me, 
anyway -- I have faith it's been cleared up. Don't mess with my faith. (Oh 
alright -- please do reopen if you're still seeing this problem on 98).
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
wfm using the 2000-01-24-01-m13 bits on winNT (non-comm) or linux
(comm). verifying.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.