long string in To Header w/attachment pane displayed causes 3 pane window (thread pane) to redraw/spaz out

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
15 years ago
8 years ago

People

(Reporter: grylchan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
using commerical trunk
2003-01-07-08-trunk on XP but I see this on all platforms

Definitly related to bug 91662.

There are 2 bugs that I see:
1)if you have mail mesg that contains a long email address in the 'to field'
  and it contains an attachment which will cause the mesg to display the
  attachment field and you view this mesg in the 3 pane window. After
  selecting/viewing it, if you click on another mesg (this mesg doesn't matter)
  it will cause:
     - the mesgs in thread pane to shift back/forth, jiggle, 
     - in some cases make the folder pane shift back/fourth and the slider
       to shift back and fourth
     - kind of looks like an earthquake :-)
  
  for ex. use a 22 char email address and use same 22 char for the
  'pretty name'
   a12345678901234567892@b.com <a12345678901234567892@b.com>

2)If you select that same mesg with the long 'To field' & attachment window
  displayed, and you try to move the slider in the 3pane window left or right:
     - it won't slide back and forth
     - instead the thread pane shifts back and forth

The key is to make the 3 pane window the 'default size'. If you make
the 3 pane window long enough(or maximize it), you won't see this problem.
Create a new profile and use that 'default' size for the 3 pane window.

reproducable: always

steps
1.Create a new profile
2.create/login to your mail acnt (i used imap)
3.compose a mesg
4.use my long 22 bogus email address above and put in the 'to field'
5.Add a attachment
6 [details].Save the mesg as draft
7.Copy that mesg to your inbox
8.Select an existing mesg
9.Select that mesg you just created/copied 
10. now select the mesg in step 8

result: you'll see thread pane shift left/right and if you have
        selected the mesg in step 9, you won't be able to
        drag slider for 3pane window left/right

expected: to not see thread pane shift left/right and be able
          to drag the slider in 3 pane window with no problems
(Reporter)

Comment 1

15 years ago
nominating. I'm seeing this in one of our qa update emails from Lisa.
The address in the 'To' field is small. But the subj line is long
(and its cut off) but there are lot of people in CC list and I have to
click twisty to expand. (twisty open or closed has no effect as the
behavior is the same). The mesg also contains an attachment (a web page
with long url)

Keywords: nsbeta1
Summary: long string in To Header w/attachment pane displayed causes 3 pane window (thread pane) to redraw/spaz out → long string in To Header w/attachment pane displayed causes 3 pane window (thread pane) to redraw/spaz out
*** Bug 190162 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
Mail triage team: nsbeta1-
Keywords: nsbeta1-

Updated

15 years ago
Keywords: nsbeta1
neil, any interest in investigating this bug?

it might end up be tree related, so cc varga.

Comment 5

15 years ago
Seth, I've got a partial workaround to this (makes the text wrap inside the
email address node) but that breaks the collapsed headers, and I don't know why yet.

I could just break the text manually at each space, but this would be slower.

Comment 6

15 years ago
I've seen it too.
I guess, it happens when you switch from a message with attachments to a message
with no attachments but with long to or cc field.
We should probably collapse attachments box first and then update fields.

Comment 7

15 years ago
But that's probably only possible if we know that the message has attachments at
the time of filling to and cc fields.

Comment 8

15 years ago
Seeing this in 1.3 final.  It's related to but not the same as Bug 91662, which
has a ton of activity (should it be considered a duplicate?). (Its comment
number 52 suggestion seems to make sense; it's got 250+ comments; I lost
patience at #75.)  I'm seeing it in emails with no attachments - I sent myself a
test email at a very long email address: 
EmailToThisAddressNotFromBugzillaIsSpamAndIsExpresslyForbiddenWithoutPayingAFeeToTEP.ByUsingThisAddressYouAgreeToTheseTermsOfUsage.YouAgreeToUseAllowOrEnableItsUseOnlyUnderTheTermsOfwww.elvey.comSlashspamoff.htm@me2004.fastmail.fm
and had to delete the message. 

Comment 9

15 years ago
Comment #8 helped me reproduce this bug.  I created a message with a long (but 
invalid) email address, and saw these symptoms in the Sent folder.  Also worked 
if I CC'd a working email address, then viewed the Inbox for that account.  
There are a couple of older bugs that are still unconfirmed which I'm checking 
to see if they are dupes of this; and bug 190820 appears to be a dupe as well, 
but has also been confirmed.

gchan@netscape.com :  you say the display "spazzes out". I see it jiggle while 
redrawing only while the splitter is actively being dragged; once you let the 
splitter go, it stabilizes.  Does that concur with your observation?  I'm trying 
to make sure there's no overlap between that symptom and Bug 201379, Bug 201460, 
Bug 201856.

Comment 10

15 years ago
See this on Solaris as well using:

Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3) Gecko/20030313

Comment 11

15 years ago
*** Bug 203366 has been marked as a duplicate of this bug. ***

Comment 12

15 years ago
*** Bug 190820 has been marked as a duplicate of this bug. ***

Comment 13

15 years ago
*** Bug 145717 has been marked as a duplicate of this bug. ***

Comment 14

15 years ago
I'm also seeing this, though additionally the scoll bar is not drawn if the
subject/attachment is extremely long.

Maximizing mozilla on an 800x600 screen (xrandr -s 800x600 is handy here) is
quite sufficient to cause it with long attachment, email, or subject lines.

The problem definitely appears to be dependent on the size of the window. As a
result, I see it a lot on our LTSP workstations (800x600 and 1024x768).

Comment 15

14 years ago
*** Bug 225985 has been marked as a duplicate of this bug. ***

Comment 16

14 years ago
*** Bug 232292 has been marked as a duplicate of this bug. ***

Comment 17

14 years ago
*** Bug 232945 has been marked as a duplicate of this bug. ***

Comment 18

14 years ago
*** Bug 223309 has been marked as a duplicate of this bug. ***

Comment 19

14 years ago
*** Bug 191848 has been marked as a duplicate of this bug. ***

Comment 20

14 years ago
When having selected one of these problematic emails, and moving the mouse
cursor over or out of the buttons in the toolbar (e.g. Get Msg (only some, not
all)), the scrollbars on the right of both the email list window and the email
window jiggle.

Comment 21

14 years ago
Created attachment 142936 [details]
Screenshot of mail (3-windows) window missing attachment window

This particular message has a very long 'To' address; It does not jiggle, but
does contain an attachment which cannot be seen nor selected (using Mozilla
1.6).  However I was able to access the attachment with GNOME Evolution sw.

Comment 22

14 years ago
*** Bug 238443 has been marked as a duplicate of this bug. ***

Comment 23

14 years ago
Moz 1.7 contains a patch for bug 63654 which I believe solves the problem of 
moving or jiggling the folder-pane splitter.  Reporter(s), can you confirm this?

It does not solve the problem of the attachment being pushed off to the right; 
that is (still) bug 91662 comment 316.  Incidentally, you can access the 
attachments via the File|Attachments menu when a message is selected, if the 
attachment box is pushed out of sight.

See also bug 240313.

Comment 24

14 years ago
*** Bug 226808 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Comment 25

13 years ago
*** Bug 175751 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Assignee: sspitzer → mail
Assignee: mail → nobody
QA Contact: laurel → message-display

Comment 26

8 years ago
(In reply to comment #23)
VERIFIED
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.