assignee/qa missing change knobs

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
Creating/Changing Bugs
P1
blocker
RESOLVED FIXED
15 years ago
5 years ago

People

(Reporter: Grzegorz Stelmaszek, Assigned: bbaetz)

Tracking

2.17.3
Bugzilla 2.18
x86
Linux
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)
Build Identifier: 

After installation of bugzilla-2.17.3 it's no longer possible to edit bugs i'm 
assigned to.

Reproducible: Always

Steps to Reproduce:




I've investigated this problem, and revealed that the cause is a bug in Bug.pm.
At the beginning of it, variable $self->{'assigned_to'} is an object of type 
Bugzilla::User. Unfortunetally later, there is an equality test made to 
evaluate canedit variable. At this point there is a type mismatch error because 
the object is compared to a string. After fixing this equality to to compare 
two ints, everything seems to work fine.
This sounds sort of like bug 186994, but not quite.
Assignee: justdave → myk
Component: Bugzilla-General → Creating/Changing Bugs

Comment 2

15 years ago
Bug 186994 is about the template not displaying the option to change the bug to
ASSIGNED when it should and is currently on bmo.  This bug appears to be a
backend issue introducted when moving to Bug.bm, which IIRC is not currently on
bmo (otherwise I'm sure we would have had far more reports).
Version: unspecified → 2.17.3
(Assignee)

Comment 3

15 years ago
Takng, but I'm unlikly to get to this before hte weekend
Assignee: myk → bbaetz
(Assignee)

Comment 4

15 years ago
Yep; this only affected the knob stuff though. Patch coming; thanks for the
diagnosis!
Severity: major → blocker
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P1
Target Milestone: --- → Bugzilla 2.18
(Assignee)

Comment 5

15 years ago
Created attachment 112272 [details] [diff] [review]
fix

We have to check that the qa_contact exists, but can't use |defined|, because
of the AUTOLOAD return. Not sure why it returns '' instad of undef, mind you,
but I'm not going to try to unravel that now...
(Assignee)

Updated

15 years ago
Attachment #112272 - Flags: review?(justdave)
Attachment #112272 - Flags: review?(justdave) → review+
Flags: approval+
(Assignee)

Comment 6

15 years ago
Fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Summary: I don't have permissions to edit a bug even I'm assigned to it → assignee/qa missing change knobs
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.