Closed Bug 1881795 Opened 3 months ago Closed 2 months ago

The OK button is not visually displayed if you use Russian in File-Offline-Download/Sync Now-Ok

Categories

(Thunderbird :: Mail Window Front End, defect)

Thunderbird 115
defect

Tracking

(thunderbird_esr115 fixed, thunderbird124 affected)

RESOLVED FIXED
125 Branch
Tracking Status
thunderbird_esr115 --- fixed
thunderbird124 --- affected

People

(Reporter: heffplay.reg, Assigned: mkmelin)

References

Details

Attachments

(5 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/122.0.0.0 Safari/537.36

Steps to reproduce:

File-Offline-Download/Sync Now-Ok

Actual results:

Thunderbird Version 115.8.0 (64-bit)
The OK button is not visually displayed if you use Russian in File-Offline-Download/Sync now-Ok. If you use the Tab key, the Ok button is highlighted (part of the blue border is visible), but it is not displayed.

Expected results:

It is not possible to press the OK button because it is not displayed.

Can you test if it's better on beta?

I am using the beta version of Thunderbird with Russian localization (currently current - 124.0b3) on Ubuntu 23.10. The problem does not reproduce.

At the same time, I see quite large spaces in the screenshot provided. Probably, screen scaling and/or non-standard screen resolution is used, which leads to such an effect.

(In reply to Valery Ledovskoy from comment #2)

I am using the beta version of Thunderbird with Russian localization (currently current - 124.0b3) on Ubuntu 23.10. The problem does not reproduce.

At the same time, I see quite large spaces in the screenshot provided. Probably, screen scaling and/or non-standard screen resolution is used, which leads to such an effect.

The standard resolution is 1920x1080. Windows scaling is not used. Thunderbird Scaling is not used, everything is default.
The problem appeared right after the first version of Thunderbird Supernova was released, I waited for them to fix it, many versions passed but the problem remained, so I wrote a report.
I tried it on different systems, including after a clean installation of Windows.
Now I will check on beta version and will report back.

In the beta version, the problem remained. Screenshots below.
Once again, the problem started with the very first version 115.0.1

Attached image 2024-03-04_20-43-57.png
Attached image 2024-03-04_20-44-19.png

The dialog resizes itself fine without an explicit height.

Assignee: nobody → mkmelin+mozilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
See Also: → 1846262
Component: Untriaged → Mail Window Front End
Target Milestone: --- → 125 Branch
Attachment #9389906 - Attachment description: Bug 1881795 - Fix msgSynchronize dialog hight issue. r=#thunderbird-reviewers → Bug 1881795 - Fix msgSynchronize dialog height issue. r=#thunderbird-reviewers

Pushed by benc@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/6c08fb86cf53
Fix msgSynchronize dialog height issue. r=vineet

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

Comment on attachment 9389906 [details]
Bug 1881795 - Fix msgSynchronize dialog height issue. r=#thunderbird-reviewers

[Approval Request Comment]
Regression caused by (bug #): not sure
User impact if declined: wrong dialog height
Testing completed (on c-c, etc.): c-c, beta 125
Risk to taking this patch (and alternatives if risky): safe

Attachment #9389906 - Flags: approval-comm-esr115?

Comment on attachment 9389906 [details]
Bug 1881795 - Fix msgSynchronize dialog height issue. r=#thunderbird-reviewers

[Triage Comment]
Approved for esr115

Attachment #9389906 - Flags: approval-comm-esr115? → approval-comm-esr115+
Duplicate of this bug: 1890944
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: