Closed Bug 1882228 Opened 4 months ago Closed 4 months ago

Error when running mach build without clobber - rename ../../dist/Firefox Nightly.app/Contents/Resources/ChannelPrefs.framework to ../../dist/Firefox Nightly.app/Contents/Frameworks/ChannelPrefs.framework: Directory not empty

Categories

(Firefox Build System :: General, defect)

defect

Tracking

(firefox-esr115 unaffected, firefox123 unaffected, firefox124 unaffected, firefox125 fixed)

RESOLVED FIXED
125 Branch
Tracking Status
firefox-esr115 --- unaffected
firefox123 --- unaffected
firefox124 --- unaffected
firefox125 --- fixed

People

(Reporter: nchevobbe, Assigned: spohl)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Maybe I'm doing something wrong or have something weird in my setup, but each time I'm doing an "incremental" mach build (so the one that would come after the "initial" build where I'm running mach clobber first), I'm getting the following error:

mv: rename ../../dist/Firefox Nightly.app/Contents/Resources/ChannelPrefs.framework to ../../dist/Firefox Nightly.app/Contents/Frameworks/ChannelPrefs.framework: Directory not empty

The only workaround I found is to run mach clobber every time, but this is way slower. For non artifact build, it can be 10mn longer than without the clobber; for artifact builds, it's only ~10s slower, but it's breaking my habits of running ./mach build faster and running.

Is it expected to always have to run clobber now?

Set release status flags based on info from the regressing bug 1799332

:spohl, since you are the author of the regressor, bug 1799332, could you take a look? Also, could you set the severity field?

For more information, please visit BugBot documentation.

Flags: needinfo?(spohl.mozilla.bugs)
Blocks: mach-busted
Component: Application Update → General
Product: Toolkit → Firefox Build System

(In reply to Nicolas Chevobbe [:nchevobbe] from comment #0)

Is it expected to always have to run clobber now?

No, it isn't. Taking a look.

Assignee: nobody → spohl.mozilla.bugs
Status: NEW → ASSIGNED
Pushed by spohl@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b6dff3a3d41b
Prevent possible errors due to directories not being empty when incrementally building macOS frameworks. r=glandium
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 125 Branch
Flags: needinfo?(spohl.mozilla.bugs)
See Also: → 1897214
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: