Integrate tabs with bookmarks in the drawer

RESOLVED WONTFIX

Status

Camino Graveyard
Tabbed Browsing
--
enhancement
RESOLVED WONTFIX
16 years ago
14 years ago

People

(Reporter: S Woodside, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

unspecified
Future
PowerPC
Mac OS X

Details

(Whiteboard: [drawer])

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

16 years ago
Integrate tabs with bookmarks in the sidebar.

Instead of having tabs appear below the toolbar, have them appear in the drawer.
Each tab in the drawer will have a context menu to "Keep in Drawer" (similar to
"Keep in Dock". If that is selected, it is equivalent to bookmarking the current
page.

When the user double-clicks on an existing bookmark, it turns into a tab.

When the user links from a page that is a bookmark, a new subentry appears in
the bookmarks bar (see "Bugzilla/Search for Bookmarks" in the example image).
The new subentry is a tab, and browsing continues from there.
(Reporter)

Comment 1

16 years ago
Created attachment 110973 [details]
Mockup of an integrated bookmarks and tabs interface in the drawer

Mockup done in photoshop. This is equivalent to having 4 tabs across the top,
for "Werblog", "80211b", "Reiter blog" and "Search for Bugs".

The shading on "Bugzilla" and the red arrows are to indicate that "Search for
Bugs" is a tab that sprung from "Bugzilla" after the user clicked a link on
"Bugzilla".

The current tab is shaded blue, and the other tabs are shaded gray.

I think maybe it's not so good to have shading on "bugzilla", maybe that's
confusing.
(Reporter)

Comment 2

16 years ago
Created attachment 111022 [details]
hybrid #2

Taking into account feedback on the list, I have made a hybrid that combines
the concept of dog-ears, bookmarks, the dock, and itunes into one package ;-)
Attachment #110973 - Attachment is obsolete: true

Comment 3

16 years ago
This seems like an incredibly confusing metaphor for normal users. First of 
all, people wouldn't understand what the name dog-ear is telling them. Also, 
what is the point in having a 'dog-ear' without it being loaded? I can't see a 
situation where that would be needed.

Even though tabs may not be consisent with the interface guidelines, I think 
they are a lot more intuitive. People understand that they are for different 
views and there are different things in each one. Mixing this with bookmarks 
would confuse people.

Also in your mockup the little arrows next to it resemble the arrows in the 
tree view below too much. At first glance for me, I thought that they were 
those arrows and you clicked on it to expand it.

I think this metaphor shows promise, but it would have to be made more clear 
that they are not bookmarks. Maybe this metaphor should be combined with the 
ideas proposed in Bug #159510
(Reporter)

Comment 4

16 years ago
The name "dog-ear" can be changed. It's the nomenclature proposed on the mailing
list.
(Reporter)

Comment 5

16 years ago
Created attachment 111324 [details]
mockup #4 (QuickMarks NoToolbar)

This is a mockup of the QuickMarks system. The QuickMarks system is best
described at the moment by Jesse Widener's post
http://www.mozdev.org/pipermail/chimera/2003-January/016317.html

This post implements most of Jesse's post, with the notable exception of the
QuickMarks toolbar (not because I dislike the QM toolbar, but I didn't have
time).

Quickmarks are roughly equivalent to the "dog-ears" of the #2mockup, and also
represent "shmoos" on a one-to-one basis. QuickMarks are application global, so
that if all the Viewer Windows are closed, and then a new Viewer Window is
opened, they are still there.
Attachment #111022 - Attachment is obsolete: true
(Reporter)

Comment 6

16 years ago
Created attachment 111725 [details]
mockup #5 -- universal drawer and two viewer windows

The Universal Drawer and Two Viewer Windows. Everything in the drawer is
application global. Sessions shows concurrent sessions.

History is possibly, instead of having a disclosure triangle, you click on it
and the Viewer Window displays the history. Or, you click the triangle, and it
display the history there. I assume most people use history temporarily, then
close it, so it doesn't interfere with use of Bookmarks and Concurrent
Sessions. There is room for about 20 concurrent sessions before bookmarks are
pushed off screen. Drag and drop is completely available (except into history)
Attachment #111324 - Attachment is obsolete: true

Comment 7

16 years ago
Tabs are popular and effective enough in both Chimera and Mozilla that I suspect
it's unlikely they'd be changed so dramatically as this.

Comment 8

15 years ago
seeing as recent changes in Camino have moved things away from the drawers is
this a WONTFIX? (even though the mockups look interesting)
(Assignee)

Comment 9

15 years ago
i'm going to leave this open for discussion, but push it out
Target Milestone: --- → Future

Updated

15 years ago
Whiteboard: [drawer]
Mike, Chris, Simon with the bookmark rewrite landed do you agree to fix this bug
has WONTFIX ?

Comment 11

15 years ago
Interestingly, OmniWeb 5 does appear to implement something like this.

Comment 12

14 years ago
Clsoing bug as the original idea isn't aplyable to the current UI chnages
concerning tabs and BM manager. Open a new bug with more updated ideas if necesarry.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.