[RFE] Allow custom headers with values to be added to outgoing messages automatically

VERIFIED DUPLICATE of bug 61520

Status

MailNews Core
Composition
--
enhancement
VERIFIED DUPLICATE of bug 61520
15 years ago
10 years ago

People

(Reporter: Lincoln Ramsay, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Habeas SWE(tm) (http://www.habeas.com/services/swe.htm) is a method of
"promising" the email you are sending is not spam. It requires adding 9 custom
headers to outbound mail. Mozilla can already be used to detect messages with
custom headers but I cannot find a way to add custom headers.

I'm not asking specifically for a "Add Habeas Headers" option as there may be
licensing issues with that. What I'm asking for is the ability to specify
per-message or globally to add certain custom headers to outgoing mail.

Reproducible: Didn't try

Steps to Reproduce:

Comment 1

15 years ago
You can do this with a hidden pref:
user_pref("mail.compose.other.header","comma-separated-list-of-headers");
in user.js.

Resolving INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

15 years ago
Setting mail.compose.other.header *allows* those headers to be set from the
compose window. It's a little tedious to write out the complete Habeas headers
for every email you send, thus the original request still stands.

I'd like a method of adding headers (including values) to every email that I
send. Unless there's a way to have Mozilla automatically fill in the headers
(which I doubt).
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: [RFE] Allow custom headers to be added to outgoing messages → [RFE] Allow custom headers with values to be added to outgoing messages automatically
(Reporter)

Comment 3

15 years ago
Just to make it clear, I'd like to do something like the following (assuming
this is only going to be available as a hidden pref):

user_pref("mail.compose.global.headers","X-Habeas-SWE-1: winter into
spring,X-Habeas-SWE-2: brightly anticipated,X-Habeas-SWE-3: like Habeas SWE
(tm),X-Habeas-SWE-4: Copyright 2002 Habeas (tm),X-Habeas-SWE-5: Sender Warranted
Email (SWE) (tm). The sender of this,X-Habeas-SWE-6: email in exchange for a
license for this Habeas,X-Habeas-SWE-7: warrant mark warrants that this is a
Habeas Compliant,X-Habeas-SWE-8: Message (HCM) and not spam. Please report use
of this,X-Habeas-SWE-9: mark in spam to <http://www.habeas.com/report/>.");

And have *all* outgoing emails to have these 9 headers added automatically.

Comment 4

15 years ago
In fact , we have already the GUI for adding basic header (from, reply-to,
organization,..)

What you need is :

1) A way to add custom header to compose window
2) A GUI similar to the supported header for setting up account wide outgoing
headers

For 1) there's already hidden prefs, but I would prefer a GUI to manage that

Without 2), I think 1) is painfull and so quite useless

(I think especially to X-Face, x-url-image that I want on all my outgoing mail)

 

Comment 5

15 years ago

*** This bug has been marked as a duplicate of 61520 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE

Comment 6

15 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.