Save Page should supply web page descriptor / cache key when calling saveURI

RESOLVED FIXED in seamonkey2.0

Status

SeaMonkey
Download & File Handling
RESOLVED FIXED
15 years ago
8 years ago

People

(Reporter: Adam Lock, Assigned: Ian Neal)

Tracking

({fixed-seamonkey2.0})

Trunk
seamonkey2.0
fixed-seamonkey2.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

15 years ago
nsIWebBrowserPersist::saveURI has a new cache key argument. The calls to saveURI
in the download progress / content area utils should make use of it.

Comment 1

14 years ago
*** Bug 196871 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
Assignee: bross2 → download-manager
QA Contact: chrispetersen

Comment 2

9 years ago
For Firefox, this was fixed in bug 84106.

The fix should probably be ported to SeaMonkey, but for a more comprehensive
solution see bug 484616.
Assignee: download → nobody
Blocks: 484616, 467530
Depends on: 84106
Flags: blocking-seamonkey2?
QA Contact: download
(Assignee)

Comment 3

8 years ago
Created attachment 399585 [details] [diff] [review]
port 84106 to SM patch v0.1

This patch:
* Ports the contentAreaUtils.js part of bug 84106 to SM.
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #399585 - Flags: superreview?(neil)
Attachment #399585 - Flags: review?(neil)
(Assignee)

Updated

8 years ago
OS: Windows XP → All
Hardware: x86 → All

Comment 4

8 years ago
Comment on attachment 399585 [details] [diff] [review]
port 84106 to SM patch v0.1

>+    cacheKey =
>+      ifreq.getInterface(Components.interfaces.nsIWebNavigation)
>+           .QueryInterface(Components.interfaces.nsIWebPageDescriptor);
.currentDescriptor surely?

>+  if (aCacheKey == undefined)
>+    aCacheKey = null;
Unnecessary.

Comment 5

8 years ago
(In reply to comment #4)
>(From update of attachment 399585 [details] [diff] [review])
>>+    cacheKey =
>>+      ifreq.getInterface(Components.interfaces.nsIWebNavigation)
>>+           .QueryInterface(Components.interfaces.nsIWebPageDescriptor);
>.currentDescriptor surely?
Bah, so as per bug 84106 currentDescriptor doesn't work in 1.9.1, so we have two options:
1. Just getInterface(Components.interfaces.nsIWebNavigation), because saveURI will work things out, assuming the page doesn't change while we're saving.
2. Actually get the necko cache key, using
cacheKey =
  ifreq.getInterface(Components.interfaces.nsIWebNavigation)
       .QueryInterface(Components.interfaces.nsIWebPageDescriptor)
       .currentDescriptor
       .QueryInterface(Components.interfaces.nsISHEntry).cacheKey;
(Assignee)

Updated

8 years ago
Blocks: 515501
(Assignee)

Updated

8 years ago
Attachment #399585 - Flags: superreview?(neil)
Attachment #399585 - Flags: review?(neil)
(Assignee)

Comment 6

8 years ago
Created attachment 399617 [details] [diff] [review]
port 84106 to SM with undefined check patch v0.1a

Changes since v0.1:
* Removed unnecessary undefined check.

Switching to using .currentDescriptor has been spun off into bug 515501 for once SM has switched to using current trunk (1.9.3.x)
Attachment #399585 - Attachment is obsolete: true
Attachment #399617 - Flags: superreview?(neil)
Attachment #399617 - Flags: review?(neil)
(Assignee)

Updated

8 years ago
Attachment #399617 - Flags: superreview?(neil)
Attachment #399617 - Flags: review?(neil)
(Assignee)

Comment 7

8 years ago
Created attachment 399622 [details] [diff] [review]
port 84106 to SM passing cacheKey patch v0.1b [Checkin: Comment 10]

Changes since v0.1a:
* Passes cacheKey through to internalSave to use with saveURI.

This can be optimised to currentDescriptor in bug 515501 once SM has switched to trunk.
Attachment #399617 - Attachment is obsolete: true
Attachment #399622 - Flags: superreview?(neil)
Attachment #399622 - Flags: review?(neil)

Comment 8

8 years ago
Comment on attachment 399622 [details] [diff] [review]
port 84106 to SM passing cacheKey patch v0.1b [Checkin: Comment 10]

I finally figured out how to test this (by saving a page from online banking).
Attachment #399622 - Flags: superreview?(neil)
Attachment #399622 - Flags: superreview+
Attachment #399622 - Flags: review?(neil)
Attachment #399622 - Flags: review+
(Assignee)

Comment 9

8 years ago
Comment on attachment 399622 [details] [diff] [review]
port 84106 to SM passing cacheKey patch v0.1b [Checkin: Comment 10]

Minor fix but a good one, requesting a=
Attachment #399622 - Flags: approval-seamonkey2.0?

Updated

8 years ago
Attachment #399622 - Flags: approval-seamonkey2.0? → approval-seamonkey2.0+
(Assignee)

Updated

8 years ago
Attachment #399622 - Attachment description: port 84106 to SM passing cacheKey patch v0.1b → port 84106 to SM passing cacheKey patch v0.1b [Checkin: Comment 10]
(Assignee)

Comment 10

8 years ago
Comment on attachment 399622 [details] [diff] [review]
port 84106 to SM passing cacheKey patch v0.1b [Checkin: Comment 10]

http://hg.mozilla.org/comm-central/rev/c701c317b3fd
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: fixed-seamonkey2.0
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Flags: blocking-seamonkey2.0?
Target Milestone: --- → seamonkey2.0
Depends on: 516189
No longer blocks: 467530
You need to log in before you can comment on or make changes to this bug.