[FLOAT] Problem with reflow around images

VERIFIED FIXED in M16

Status

()

defect
P3
minor
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: rev-bob, Assigned: buster)

Tracking

Trunk
x86
Windows 98
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments)

Given the code below, the bottom two lines to the right of the seal are not
moved to their correct placement when the image dimensions are discovered,
instead staying on top of the seal.  Refreshing the page corrects the display
error.

This happens consistently on Win32 builds 1999110809 and 1999111308.

<html>
<body>
<body bgcolor='#ffffff' text='#000000' link='#4040C0' vlink='#551a8b'>
<div align="center"><img src="http://www.ulc.org/ulcall/topbord.gif"
alt=""></div>
<div align="center"><img src="http://www.ulc.org/ulcall/ulclogo.gif"
alt="Universal Life Church Minister"></div>
<br><img align="left" hspace="40" vspace="20"
src="http://www.ulc.org/ulcall/ulcseal.gif" alt="Universal Life Church Official
Seal">
<span style="font-size: xx-large; ">T</span><span style="font-size: small; ">
his is to certify that the bearer hereof</span>
<p><span style="font-size: large; "> R</span><span style="font-size:
medium; "><strong>everend</strong></span>
<span style="font-size: x-large; ">Robert L. Hood</span>
<br><br>
<span style="font-size: small; ">has been ordained this Eleventh day of March,
1996.</span><br clear="left">
<img src="http://www.ulc.org/ulcall/kirbysig.gif" alt="Official Signature"
align="right"><br clear="right"><div align="center"><br><br>
<span style="font-size: xx-small; ">
<strong>HEADQUARTERS:</strong> 601 3RD ST., MODESTO, CALIF. 95351 (209) 527-
8111</span></div>
</body>
</html>
Assignee: troy → kipp
Worksforme; reflow seems to work with local copy of given html-snippet and
pictures. I tested with NT4.0 sp 4, M11-fullcircle prebuild version.
*** Bug 20374 has been marked as a duplicate of this bug. ***
Updating to default Layout Assignee...kipp no longer with us :-(
Why are you re-reassing layout bugs? Do NOT touch layout bugs.

The bugs are assigned to Kipp so they can stay neatly organized until we have a
new owner for the block/inline code.
mass moving all Kipp's pre-beta bugs to M15.  Nisheeth and I will
prioritize these and selectively move high-priority bugs into M13 and M14.
Summary: Problem with reflow around images → [FLOAT] Problem with reflow around images
I am using Linux and the 2000020509 build.

It appears that if the height and width are not defined in the html for image,
the text will not wrap properly. I will attach two test cases, one has the bug,
the other does not.
Posted file This one does not.
mine! mine mine mine!  all mine!  whoo-hoo!
Assignee: kipp → buster
There are two bugs reported here.  The first (the test case in the initial 
report) is a problem with incremental reflow of text in a block around a float 
whose size changes dynamically.  In this case, the image size changes because 
the <IMG> tag has no dimensions specified, and the IMG resizes when the actual 
image data is resolved.  I have the fix for this (not yet checked in.)

The second problem (the test cases submitted by saschmit@unity.ncsu.edu) has to 
do with repainting too little when a block frame with a bullet is moved in 
response to an incremental reflow.  This is a much more minor problem.  I split 
this second problem off to bug 33504.
Blocks: 33504
Whiteboard: fix in hand
I'm not sure how to read buster@netscape.com's comment, so I'll just say this: 
It's not so minor a bug if you can't click the links that are over the images to 
get to where they go instead of where the image goes--I suppose my test case 
should have had the links go different places, but I hadn't thought of that 
when I made them.
by "minor" I meant that the *remaining* problem is both easy to fix, and has 
relatively small end-user impact.  I can say this because with the fix I'm going 
to check in for this bug, I believe the content all shows up in the correct 
place, just some of it doesn't paint correctly.  Anything that forces a repaint 
will fix the display, and the links should be clickable regardless.  Fixing this 
problem should just be a matter of computing a sufficiently large damage rect, 
which I'm guessing isn't being done only because the <LI> include "special" 
content (the bullets) that expand their width beyond what the block code 
typically considers "normal."  It's a pretty simple calculation to get right, 
but that's not what I'm working on yet.
*** Bug 18560 has been marked as a duplicate of this bug. ***
moving all buster m15 bugs to m16.
Target Milestone: M15 → M16
*** Bug 32567 has been marked as a duplicate of this bug. ***
fix checked in.  should be able to verify against 4/17/00 build.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Whiteboard: fix in hand
Blocks: 34892
Fixed in the July 6th build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.