Closed Bug 1882748 Opened 4 months ago Closed 3 months ago

If only WebDriver BiDi is enabled no recommended preferences are applied

Categories

(Remote Protocol :: Agent, defect, P2)

defect
Points:
2

Tracking

(firefox125 fixed)

RESOLVED FIXED
125 Branch
Tracking Status
firefox125 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

References

(Blocks 1 open bug)

Details

(Whiteboard: [webdriver:m10][webdriver:relnote])

Attachments

(1 file)

We are not applying any recommended preferences when only WebDriver BiDi is enabled and gets started:
https://searchfox.org/mozilla-central/rev/0e7394a77cdbe1df5e04a1d4171d6da67b57fa17/remote/webdriver-bidi/WebDriverBiDi.sys.mjs#171

This only happens for CDP:
https://searchfox.org/mozilla-central/rev/0e7394a77cdbe1df5e04a1d4171d6da67b57fa17/remote/cdp/CDP.sys.mjs#79

We should always apply general automation related preferences applying to all supported protocols when at least one protocol is enabled and doesn't have own recommendations.

Blocks: 1872254
Blocks: 1883355
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f14d32a7cc44
[remote] Always apply recommended common preferences. r=webdriver-reviewers,jdescottes
Blocks: 1882085
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 125 Branch
Points: --- → 2
Priority: -- → P2
Whiteboard: [webdriver:m10]
Whiteboard: [webdriver:m10] → [webdriver:m10][webdriver:relnote]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: